LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   QMAIL error:554 Transaction failed: message format error (http://www.linuxquestions.org/questions/linux-software-2/qmail-error-554-transaction-failed-message-format-error-179972/)

mpk25 05-10-2004 11:44 AM

QMAIL error:554 Transaction failed: message format error
 
Hello,
we have be running a qmail e-mail server server for about two years at my company. Last week friday I got an email from a higher up in the company saying that he got a bounced email when he was trying to contact the state health department. I have had no messages from anyone else bounce back like this. I thought it was a wierd message to get (I haven't messed with the email server in weeks, :D ). I talked to one of their admins who was able to send me a test message, however when i replied to the message the message below is what bounced back.

-we run qmail 1.06
-have amavis running with CLAM

Here it is:
The original message was received at Mon, 10 May 2004 10:21:46 -0600
from [63.x.x.x]

----- The following addresses had permanent fatal errors -----
<x>@cdhs.state.co.us
(reason: 554 Transaction failed: message format error)
(expanded from: <x.x@state.<x>.us>)

----- Transcript of session follows -----
... while talking to <x>.state.<x>.us.:
>>> DATA
<<< 554 Transaction failed: message format error
554 5.0.0 Service unavailable



My understanding of qmail is limited. What would cause an error like this? I contacted their administrator and they seem to think that it is a problem on our side. Any info would be greatly appreciated!

mpk25 10-15-2004 12:53 PM

The Fix
 
Turns out that this was a combination of issues.:

-The mc-afee webshield can sometimes cause this problem. After numerous google searches it came up in the fix log for service pack 1 for the appliance


-Amavis was adding X-headers to each email saying that it was scanned. Evidently some email servers don't like receiving mail that has been scanned... :scratch:
I had to simply edit the amavis.conf file to remove the X-headers from being inserted into the email


just an FYI for any other email server admins that run into this problem like I did. :study:


All times are GMT -5. The time now is 09:19 AM.