LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-09-2004, 05:06 AM   #1
jkassemi
Member
 
Registered: May 2004
Location: Albuquerque, NM
Distribution: slackware-current, slamd64-11
Posts: 106

Rep: Reputation: 15
python and bittorrent dependencies


When I attempt to install bittorrent I get the following error message:

[blah@localhost Desktop]$ rpm -i bittorrent-3.4.2-1mdk.noarch.rpm
warning: bittorrent-3.4.2-1mdk.noarch.rpm: V3 DSA signature: NOKEY, key ID 26752624
error: Failed dependencies:
python-base >= 2.3 is needed by bittorrent-3.4.2-1mdk
python-base is needed by bittorrent-3.4.2-1mdk

I can type "python" to get the version and I find:

Python 2.3.3 (#1, May 3 2004, 02:57:26)
[GCC 3.3.2 20031022 (Red Hat Linux 3.3.2-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.


So I do have an appropriate python version... but I need some help figuring out how to bypass this error. I'm a newbie.

Appreciate the help:

James
 
Old 05-09-2004, 12:02 PM   #2
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
Maybe you installed python 2.3.3 from source, rather than through rpm. Try rpm -q python to check what version rpm thinks it's got.

You could also try using the --nodeps flag which tells rpm not to bother doing a dependency check before installing. This might result in having an installed version of bittorrent which doesn't work (if the problem is something else, like a location or permissions issue) so you might have to deinstall it to tidy up.
 
Old 05-09-2004, 04:39 PM   #3
jkassemi
Member
 
Registered: May 2004
Location: Albuquerque, NM
Distribution: slackware-current, slamd64-11
Posts: 106

Original Poster
Rep: Reputation: 15
thanks for the quick response. When I type the following I get:

[jkassemi@localhost jkassemi]$ rpm -q python
python-2.2.3-7

which is interesting. I thought that if I compiled the source code (./configure, make, make install) that it would install the program for me... hmmm... so what do I need to do exactly?

Thanks,
James
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Python and Bittorrent jorisb Linux - Software 1 10-02-2004 04:21 PM
Bittorrent: python errors davoman Linux - Software 2 04-16-2004 03:45 PM
BitTorrent 3.4.1a dependencies xilace Linux - Newbie 1 04-04-2004 07:42 AM
bittorrent without python.(azureus??) arunshivanandan Linux - Software 7 11-01-2003 11:05 AM
bittorrent and python mercutio Linux - Software 7 09-01-2003 07:06 PM


All times are GMT -5. The time now is 10:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration