LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-10-2004, 07:11 PM   #1
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 262

Rep: Reputation: 30
pygtk-2.0 install problem??


I'm trying to install gDesklets for GNOME on Slackware 9.1, I have checked the dependencies for it, and it requires:

- Python 2.x or higher (2.3 recommended)
- libgtop2
- GConf
- gnome-python 1.99.17 or higher (2.0.0 recommended)

GConf and libgtop2 I have, Python 2.3 is now installed, but gnome-python 2.0 requires a package called pygtk-2.0

I have pygtk-2.0 but on ./configure it produces this:

Quote:
checking LIBGLADE_CFLAGS... -I/usr/include/libglade-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libxml2 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking LIBGLADE_LIBS... -Wl,--export-dynamic -lglade-2.0 -lgtk-x11-2.0 -lxml2 -lpthread -lz -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
checking for gtkgl-2.0 >= 1.99.0... Package gtkgl-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtkgl-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtkgl-2.0' found

checking for Numeric/arrayobject.h... no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating pygtk-2.0.pc
config.status: creating codegen/Makefile
config.status: creating gtk/Makefile
config.status: creating docs/Makefile
config.status: creating codegen/pygtk-codegen-2.0
config.status: creating pygtk.spec
config.status: creating PKG-INFO
config.status: creating config.h
config.status: executing depfiles commands
root@MACHINEX:~/gDesklets/pygtk-2.0.0#
Now I discovered that gtkgl-2.0 is in the package GTKGLArea-1.99, so I tried that and got this during the "make" :



Quote:
make[1]: Entering directory `/root/.Trash/gtkglarea-1.99.0/gtkgl'
/bin/sh ../libtool --mode=link gcc -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -g -O2 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -o libgtkgl-2.0.la -rpath /usr/local/lib -version-info 1:0:0 gdkgl.lo gtkglarea.lo -Wl,--export-dynamic -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lGLU -lGL
libtool: link: `/usr/lib/libGL.la' is not a valid libtool archive
make[1]: *** [libgtkgl-2.0.la] Error 1
make[1]: Leaving directory `/root/.Trash/gtkglarea-1.99.0/gtkgl'
make: *** [all-recursive] Error 1
root@MACHINEX:~/gDesklets/gtkglarea-1.99.0#
So now I don't know where else to take it? I haven't even begun to install gnome-python yet, let alone gDesklets!

Thanks,
 
Old 01-10-2004, 08:13 PM   #2
teval
Member
 
Registered: Jul 2003
Location: Toronto, Canada
Distribution: Gentoo
Posts: 720

Rep: Reputation: 30
Your error lies in the setup of GL on your computer.

libtool: link: `/usr/lib/libGL.la' is not a valid libtool archive

That's your problem. Try setting GL up (your graphics card if it's nvidia will set things up for you, just reinstall the driver)
 
Old 01-10-2004, 08:33 PM   #3
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 262

Original Poster
Rep: Reputation: 30
I only installed the latest driver 2 hours before I tried, and Slackware was only installed from scratch yesterday - NVIDIA version 1.0-5328, on an Nvidia GeForce4 MX440.

This is the second time I have had this problem, I never solved it the first time because Partition Magic crashed halfway through resizing my drive and b0rked everything, making me reinstall from scratch...

Is there anyway to set up GL without reinstalling the drivers, as I've only just done it? Or is there anything else I could investigate?

Thanks

Last edited by morrolan; 01-10-2004 at 08:44 PM.
 
Old 01-13-2004, 12:53 PM   #4
mitchcat
LQ Newbie
 
Registered: Jan 2004
Location: Davis, CA
Distribution: Suse 10.2, KDE 3.5
Posts: 10

Rep: Reputation: 0
libGL.la not libtool archive

I had a very similar problem tying to compile koffice. Google search turned up "Nvidia Installer HOWTO for SuSE Linux users" (http://distro.ibiblio.org/pub/Linux/...nstaller-HOWTO) . I'm running Red Hat, so didn't think it could apply. After pulling my hair out a bit, I checked it out. Search on "libGL.la" to find:

X. Known issues with release 1.0-5328
-------------------------------------
People report that using libtool with release 1.0-5328 fails with:

"libtool: link: `/usr/lib/libGL.la' is not a valid libtool archive"

nvidia comments on this:

--
This is a problem with the libGL.la generated by the
nvidia-installer. Please edit /usr/lib/libGL.la, and replace the line:

# Generated by nvidia-installer: 1.0.5

with

# Generated by nvidia-installer: 1.0.5 (for use by libtool)

libtool greps for "^# Generated by .*libtool" before using .la files.

This will be fixed in the next driver release. I apologize for the
inconvenience.

Andy Ritger
NVIDIA Corporation


It fixed it for me, I hope it works for you!

Mitch
 
Old 01-13-2004, 02:31 PM   #5
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 262

Original Poster
Rep: Reputation: 30
You are the master!

I'd pretty much given up on this thread, but I'll try that as soon as I get home and let you know my results!

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with PyGTK on_the_grid Programming 3 03-17-2005 04:57 AM
pygtk install found 2 versions of glib and complains Kanaflloric Linux - Software 1 09-28-2004 05:46 AM
gdesklets and pygtk problem lyceum Linux - Newbie 5 07-06-2004 01:16 AM
pygtk-2.0 not found during install of gnome-python? morrolan Linux - Software 9 02-02-2004 02:13 AM
Cannot Install PyGTK drxsmurf Linux - Software 8 10-20-2003 01:13 AM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration