LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   pygame (http://www.linuxquestions.org/questions/linux-software-2/pygame-60747/)

kierwind 05-20-2003 12:02 AM

pygame
 
i'm having trouble with installing the RPM package for Pygame, a language to run games. i've solved all but 1 dependency.

The specific details is as follows:

# rpm -ivh pygame-1.5.5-1.i386.rpm
error: Failed dependencies:
libvorbisfile.so.0 is needed by pygame-1.5.5-1

Now when i tried to install libvorbis package conatining this file,

# rpm -ivh libvorbis-1.0rc3-1.i386.rpm
error: Failed dependencies:
libogg >= 1.0rc3 is needed by libvorbis-1.0rc3-1

And when i tried to install libogg version 1.0rc3,

# rpm -ivh libogg-1.0rc3-1.i386.rpm
Preparing... ########################################### [100%]
package libogg-1.0-4 (which is newer than libogg-1.0rc3-1) is already installed
file /usr/lib/libogg.so.0 from install of libogg-1.0rc3-1 conflicts with file from package libogg-1.0-4

knowing that libogg is already installed into my system,

# rpm -Uvh libogg-1.0rc3-1.i386.rpm
warning: libogg-1.0rc3-1.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
libogg >= 2:1.0 is needed by (installed) libvorbis-1.0-7
libogg = 1.0 is needed by (installed) libogg-devel-1.0-4

trying to remove libogg is impossible, since so many other programs are dependent on it.

How do i go about this problem? i'm so close but yet so far....any help would be appreciated...thanx!

mhearn 05-20-2003 06:03 AM

Hmm, you should already have libvorbisfile. Run

/sbin/ldconfig -p | grep vorbisfile

and see if it appears. You should fill out what distro you're using in your user profile, that will help you get better answers.

It may be borked packaging, in which case you might want to run RPM with --nodeps

iceman47 05-20-2003 06:26 AM

Maybe you could try installing a newer libvorbis (1.0-7 is the newest I could find on rpmfind http://www.rpmfind.net/linux/rpm2htm...mit=Search+...)

acid_kewpie 05-20-2003 06:29 AM

well you're trying to install a set of files which are older than some of the ones already installed. get the newest versions from rpmfind.net and install those. -Uvh-ing all the time.

kierwind 05-20-2003 09:13 PM

I;m currently using Red Hat 9.0

Indeed i already do have libvorbis version 1.0 release 7 installed....in that case how should i get the program to work? will --nodeps really work?

mhearn 05-21-2003 04:19 AM

Well --nodeps overrides the dependancy checks. So yes. But, it's not actually a cure as such, the dep checks are there for a reason. Unfortunately sometimes they go wrong. Try it.


All times are GMT -5. The time now is 07:44 AM.