LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-29-2003, 11:48 PM   #1
MRK
Member
 
Registered: Jan 2002
Posts: 60

Rep: Reputation: 15
Pure-FTPD Problems


I just installed Pure-FTPD. I can start the server just fine. I can connect to it locally just fine and browse through it just fine. But whenever i get on my home computer, i can connect to it, but it just sits there trying to list the directory and eventually timesout. Here is the log:

Quote:
~ Connecting...
~ Connected to mattrk.com, waiting for response...
< 220---------- Welcome to Pure-FTPd ----------
< 220-You are user number 4 of 50 allowed.
< 220-Local time is now 22:46. Server port: 21.
< 220 You will be disconnected after 15 minutes of inactivity.
> USER mattrk
< 331 User mattrk OK. Password required
> PASS *****
< 230-User mattrk has group access to: mattrk
< 230 OK. Current directory is /home/mattrk
> REST 1
< 350 Restarting at 1. But we're in ASCII mode
> REST 0
< 350 Restarting at 0
> SYST
< 215 UNIX Type: L8
> PWD
< 257 "/home/mattrk" is your current location
~ Login completed.
> PASV
< 227 Entering Passive Mode (192,168,1,2,143,106)
> TYPE A
< 200 TYPE is now ASCII
> LIST
! Socket Error: no connection
~ Could not retrieve directory listing for "/"
~ Disconnected
My first problem was that i was behind a router and a firewall. So i had to tell my client to use passive mode. So now, i can connect, but it wont list the directory. I'm stumped. Does anyone know what is causing this? Thanks for any help you can provide.

-Mr.K

Last edited by MRK; 06-29-2003 at 11:49 PM.
 
Old 06-30-2003, 01:40 AM   #2
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
habitually, if you can't list directory, it's because you're using Active mode and that your firewall/router/provider deny it.

Are you SURE you turned off the "active mode" feature in your ftp client?

Try to connect then type netstat -a on the client (no matter what's the OS, windoze have this command too, since Micro$oft copyied the BSD code) and post the output here.
 
Old 06-30-2003, 12:49 PM   #3
MRK
Member
 
Registered: Jan 2002
Posts: 60

Original Poster
Rep: Reputation: 15
I got it working last night. I put my server into the dmz and deleted all the port forwards for the machine. I then told pureftpd to start normally without any options. I tried to connect to it, and i succeeded. I was then able to turn passive mode off and connect. I then took the server out of the dmz and put a port forward to forward any request on port 21 to the machine and everything works. I'm not quite sure what i did, but it works now. Thanks for your help though!

-Mr.K
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pure-ftpd roofy Linux - Software 6 03-05-2007 05:06 AM
Pure-ftpd Yoinx Linux - Software 0 10-18-2004 01:12 PM
Pure-FTPd, Anonymous account problems. LYNZH Linux - Software 0 09-17-2004 09:26 AM
Problems using Pure-FTPd server... mike_hurley Linux - Networking 1 11-12-2003 01:58 PM
Pure-ftpd help ksgill Linux - Newbie 15 04-18-2003 01:24 AM


All times are GMT -5. The time now is 10:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration