LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-21-2008, 02:02 PM   #1
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Rep: Reputation: 16
Pulseaudio


Hi,

After I started to use OpenSUSE 11 I face problems with Pulseaudio.
It happens quite often that I cannot control sound volume.
When I double click the button (volume control) it says:
Connection failed: connection refused

In terminal I observe following:
Code:
rafal@linux-39sr:~/Desktop> pulseaudio -D
W: core-util.c: setpriority(): Brak dostępu
rafal@linux-39sr:~/Desktop>
"Brak dostępu" means "Permission denied".

When I start XMMS I can here the sound and even control the volume with pulse. The only problem is that if I double click on the control button there is the message "Connection failed: connection refused".

Restarting PC not always help. I think the problem could be after I install some new packages.

Since ALSA works fine, when I restart it, it does not help:

Code:
linux-39sr:/home/rafal/Desktop # /etc/init.d/alsasound restart
Shutting down sound driver            done
Starting sound driver:  hda-intel     done
/var/log/messages says:
Code:
Aug 21 20:30:37 linux-39sr gnomesu-pam-backend: pam_unix2(gnomesu-pam:auth): conversation failed
Aug 21 20:30:48 linux-39sr pulseaudio[4196]: pid.c: Stale PID file, overwriting.
Aug 21 20:30:48 linux-39sr pulseaudio[4196]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operacja niedozwolona
Aug 21 20:30:48 linux-39sr pulseaudio[4196]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operacja niedozwolona

(...)

Aug 21 20:44:53 linux-39sr pulseaudio[4949]: pid.c: Daemon already running.
Aug 21 20:44:53 linux-39sr pulseaudio[4949]: main.c: pa_pid_file_create() failed.
When I check here:
https://bugzilla.novell.com/show_bug.cgi?id=359441, then for me it looks like solved bug, but in fact it isn't.

What can I do/check in order to solve it?
It really annoys me, because whenever it happens I cannot use SKYPE (it says there is problem with audio)

regards
Rafal
 
Old 08-23-2008, 04:28 AM   #2
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Original Poster
Rep: Reputation: 16
pulseaudio - update

Unfortunatelly nobody interested in this thread ;-(



I have tested with pulse audio 0.9.10.0

Code:
rafal@linux-39sr:/dane/rapid> pulseaudio --version
pulseaudio 0.9.10
...and pulseaudio 0.9.10.26.3 available from Suse-updates page.
Strange , because this version was released in March 2008 and on the page pulseaudio.org I found version 0.9.11 from 2008-07-24, which I gonna to test now.
I have found rpm's here: http://software.opensuse.org/search (pulseaudio-0.9.11-4.1.i586.rpm). Strage that it is not visible via YaST (apparently another repository)

Sad to say but if I compare sound recording quality with Windows , then Linux is worse.

regards
Rafal

Last edited by RAFAL; 08-23-2008 at 04:33 AM.
 
Old 08-23-2008, 05:06 AM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,561
Blog Entries: 1

Rep: Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023Reputation: 1023
I know that it doesn't solve your problem, but when I had problems with pulseaudio, after a week of struggling
with it, I just removed pulseaudio and used good old alsa.
 
Old 08-23-2008, 05:23 AM   #4
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Original Poster
Rep: Reputation: 16
alsa

not bad idea.
First I will give a new version of pulseaudio a chance, then will think what next
 
Old 08-23-2008, 05:42 AM   #5
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Original Poster
Rep: Reputation: 16
skype not working

not good ;-(
after pulseaudio update skype (2.0.0.72) is not working anymore:

Code:
rafal@linux-39sr:~/Desktop> skype
skype: pcm_pulse.c:296: pulse_write: Warunek zapewnienia `pcm->last_size >= (size * pcm->frame_size)' nie został spełniony.
Przerwane
"Warunek" means condition. It was not met (`pcm->last_size >= (size * pcm->frame_size)').

reinstallation of Skype does not help ;-(

any ideas?
 
Old 08-23-2008, 05:46 AM   #6
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by RAFAL View Post
skype (2.0.0.72) is not working anymore:
I have found bad news here (similar problem);
http://www.spinics.net/lists/fedora-.../msg70472.html

Quote:
You're wasting your time. skype is closed-source. There's no debuginfo
and we can't fix any problems in it.

Talk to skype about it. We can't help you fix closed-source software.

Maybe http://support.skype.com/ will help.
 
Old 08-23-2008, 01:57 PM   #7
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Original Poster
Rep: Reputation: 16
skype is working again

I was able to make skype working again.

Here what I have done:
- I unistalled skype
- I removed .Skype from my home folder. This is important!
- I installed skype

Now, when I type skype I am able to run the program, but whenever I change audio settings in skype to pulse it gives me this error:
Quote:
rafal@linux-39sr:~/Desktop> skype
skype: pcm_pulse.c:296: pulse_write: Warunek zapewnienia `pcm->last_size >= (size * pcm->frame_size)' nie został spełniony.
Przerwane
...so for me this confirms that skype problem is definitely connected to pulse
 
Old 08-23-2008, 03:37 PM   #8
RAFAL
Member
 
Registered: Feb 2006
Location: Warsaw, Poland
Distribution: openSUSE 11.4, openSUSE 12.3, SLES 11, Archlinux
Posts: 129

Original Poster
Rep: Reputation: 16
End of the story ;-)

I uninstalled Pulseaudio from my computer (thanks sycamorex!)...and suddenly :
- skype works fine ;-)
- recorded sound quality is much much better ! ;-) and there are no noices when I call with skype
- no crashes with "pcm_pulse.c:296: pulse_write" ;-) (not only skype crashed...Real Player did the same)

The only problem was, that I had to remove volume control button from the desktop and to make new to "gnome-volume-control". In addition I had to reinstall XMMS, because it crashed otherwise (probably was looking for pulse).

regards
Rafal

Last edited by RAFAL; 08-23-2008 at 03:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pulseaudio kde4 sycamorex Linux - Software 5 01-07-2010 03:32 PM
PulseAudio permissions issue pauledwards03 Linux - Software 1 07-15-2008 07:47 PM
pulseaudio +Mic problems setlec_seta Mandriva 4 06-08-2008 06:07 PM
pulseaudio replaces esound? lugoteehalt Debian 3 07-20-2007 12:12 PM
pulseaudio, which modules to load? lugoteehalt Linux - Software 2 07-19-2007 08:59 AM


All times are GMT -5. The time now is 08:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration