LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-20-2003, 04:29 PM   #1
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 379

Rep: Reputation: 31
ptoblems installing MPlayer


I did my install trough rpms... something went wrong...
####################################################
Here is my error output:
####################################################

Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale


MPlayer 0.90-RPM-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/ferdna/.mplayer/config
[cfg] read config file: /home/ferdna/.mplayer/gui.conf
Reading config file /home/ferdna/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/ferdna/.mplayer/codecs.conf: can't open '/home/ferdna/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/ferdna/.mplayer/font/font.desc
Syntax error in font desc: name 'File generated for koi8-r encoding using `Arial Regular' face (/mnt/DOS_C/winnt/Fonts/arial.ttf), ppem=24 by Nick Kurshev nickols_k@mail.ru'

Can't load font bitmap: arpi_osd_a.raw
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/ferdna/.mplayer/input.conf : No such file or directory
Input config file /etc/mplayer/input.conf parsed : 52 binds
SKIN dir 1: '/home/ferdna/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
[skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
Skin not found ( default ).
 
Old 04-20-2003, 04:46 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well you've not got the skin rpm installed i'd guess
 
Old 04-20-2003, 04:50 PM   #3
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
Hi there! Well I hope this helps:
Go here: MPlayer website
and download the default skin. Then extract it to the directory that the error states it should be (/usr/share/mplayer/Skin/) Hope this helps!
 
Old 04-20-2003, 04:51 PM   #4
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
Damn I hate it when someone answers while I'm writing my answer
 
Old 04-20-2003, 04:56 PM   #5
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 379

Original Poster
Rep: Reputation: 31
acid_kewpie:

i did installed some skin package the Blue one...
don't know if thats the one i need!

wonderpun:
please tell me how to do this... don't really know what to do!
 
Old 04-20-2003, 04:58 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
yes, but that is not going to be called "default" now is it?! what you should be able to do is to edit .mplayer/gui and change "gui_skin = "default"" to your own skin, that might work i guess.... alternatively symlink the directory for that skin to "default"
 
Old 04-20-2003, 05:21 PM   #7
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
Well actually Blue is the default mplayer skin, only that they forgot to change it's name from Blue to default I guess acid's right FreakBoy. Go to your home directory and from there open the file .mplayer/gui and then change the line:
gui_skin = "default"
into:
gui_skin = "Blue"
that should work. Good luck!
 
Old 04-20-2003, 05:26 PM   #8
wr3ck3d
Member
 
Registered: Dec 2002
Location: IL
Distribution: NetBSD, Slackware, Gentoo, Debian, FreeBSD
Posts: 444

Rep: Reputation: 31
I was having that problem this morning, i just renamed the Blue folder to default.
 
Old 04-20-2003, 05:28 PM   #9
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 379

Original Poster
Rep: Reputation: 31
i guess it worked... but i still can't see the gui...
when i type 'gmplayer' i nothing happens! and
don't really know what to do now! i changed my
~/.mplayer/config now i don't get any errors but
still don't get my gui
 
Old 04-20-2003, 05:29 PM   #10
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
That's an idea too
 
Old 04-20-2003, 05:29 PM   #11
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well you must get *something*....
 
Old 04-20-2003, 05:30 PM   #12
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 379

Original Poster
Rep: Reputation: 31
can u guys post ur gui files cuz i don 't have one!!!
or email it to me!??
 
Old 04-20-2003, 05:30 PM   #13
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
Freakboy, do you get any errors? Maybe you didn't install the Fonts?

P.S. Now that I think about it I remember that the gui file is created when you run the gui for the first time

Last edited by wonderpun; 04-20-2003 at 05:32 PM.
 
Old 04-20-2003, 05:32 PM   #14
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 379

Original Poster
Rep: Reputation: 31
if i type gmplayer -gui i get this:


[ferdna@dnacore ferdna]$ gmplayer -gui
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale


MPlayer 0.90-RPM-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/ferdna/.mplayer/config
Warning unknown option gui_skin at line 3
[cfg] read config file: /home/ferdna/.mplayer/gui.conf
Reading config file /home/ferdna/.mplayer/gui.conf: No such file or directory
The gui option can't be used on the command line
[ferdna@dnacore ferdna]$
 
Old 04-20-2003, 05:34 PM   #15
FreakboY
Member
 
Registered: Jun 2002
Location: TX, USA
Distribution: Slackware
Posts: 379

Original Poster
Rep: Reputation: 31
if i type gmplayer:

[ferdna@dnacore ferdna]$ gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale


MPlayer 0.90-RPM-3.1 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with Runtime CPU Detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/ferdna/.mplayer/config
Warning unknown option gui_skin at line 3
[cfg] read config file: /home/ferdna/.mplayer/gui.conf
Reading config file /home/ferdna/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/ferdna/.mplayer/codecs.conf: can't open '/home/ferdna/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/ferdna/.mplayer/font/font.desc
Syntax error in font desc: name 'File generated for koi8-r encoding using `Arial Regular' face (/mnt/DOS_C/winnt/Fonts/arial.ttf), ppem=24 by Nick Kurshev nickols_k@mail.ru'

Can't load font bitmap: arpi_osd_a.raw
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/ferdna/.mplayer/input.conf : No such file or directory
Input config file /etc/mplayer/input.conf parsed : 52 binds
SKIN dir 1: '/home/ferdna/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
[skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
Skin not found ( default ).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help installing mplayer newbe45 Linux - Software 45 08-26-2004 11:28 AM
portable computers and linux. Ptoblems? alexey Linux - Hardware 1 07-01-2004 02:50 PM
Installing Mplayer.... ChaosZ3RO Linux - Software 4 02-23-2004 10:03 PM
How to install mplayer gui after installing mplayer kaega2 Linux - Software 5 10-07-2003 11:44 AM
installing mplayer ramu_ak Linux - General 41 06-30-2003 07:28 PM


All times are GMT -5. The time now is 02:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration