LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-14-2011, 04:21 PM   #1
spaceboy909
LQ Newbie
 
Registered: Mar 2008
Location: Missouri, USA
Distribution: Mint 10 LXDE/XFCE
Posts: 21

Rep: Reputation: 0
Question Proper way to replace Glib; need to build GTK3.0 for Anjuta 3.0


Hi all. I've gone about as far as I can with this without trashing my system. I'm running Mint 10 LXDE with XFCE.

Ultimate objective: Install latest Anjuta 3.0 from source (not yet in repos)

Anjuta ./configure reported a need for updated packages, such as GTK 3.0, Glib, Gio, etc.

I downloaded GTK 3.0 and 'config' reported a need for an updated Glib. So I downloaded that and have installed it successfully (no prefixes; from home dir.)

But now GTK config is stating that it has found two versions of Glib, which I guess makes sense since I made no attempt to replace the old one.

So, what is/was the proper way to replace the old Glib so there is only one version, or, is that a bad idea? Will some software still be dependent on the old Glib, or do the devs make the libraries backward compatible? Where do I go from here?

Quote:
checking for GLIB - version >= 2.28.0...
*** 'pkg-config --modversion glib-2.0' returned 2.28.6, but GLIB (2.26.1)
*** was found!
If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.28.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.
 
Old 05-14-2011, 07:27 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
You are facing an uphill battle. You do need to remove the newer version of glib.

Your best bet would be to use the GNOME Jhbuild tool to build a gtk-3.0 enviornment at an alternate prefix ( either in your home directory or somewhere in /opt, such as /opt/gnome )

http://live.gnome.org/Jhbuild

You are probably going to have to build one of the following modulesets

Code:
http://git.gnome.org/browse/jhbuild/plain/modulesets/gnome-apps-3.2.modules
http://git.gnome.org/browse/jhbuild/tree/modulesets/gnome-apps-3.0.modules
 
Old 05-14-2011, 07:31 PM   #3
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,210

Rep: Reputation: 238Reputation: 238Reputation: 238
Quote:
Originally Posted by spaceboy909 View Post
So, what is/was the proper way to replace the old Glib so there is only one version, or, is that a bad idea? Will some software still be dependent on the old Glib, or do the devs make the libraries backward compatible? Where do I go from here?
Normally, installing a new version removes the old version. Are you sure one isn't 32-bit and the other 64-bit?
I'd try removing the old version - if the removal software doesn't object, it's not likely to break anything. If there's an objection, I'd definitely reconsider.
 
Old 05-15-2011, 07:12 PM   #4
spaceboy909
LQ Newbie
 
Registered: Mar 2008
Location: Missouri, USA
Distribution: Mint 10 LXDE/XFCE
Posts: 21

Original Poster
Rep: Reputation: 0
Thanks for the tips guys, but it seems I'm getting in over my head on this, and this is not a necessity.

I think I'll just stick with my current version of Anjuta, and hopefully, Mint 11 will have GTK 3.0 support.
 
  


Reply

Tags
anjuta, glib, gtk, remove


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
my anjuta cant build.can anybody please help??? calicratis19 Programming 1 09-24-2008 02:38 AM
Anjuta can not build a project.... TaoK Programming 0 12-09-2007 08:04 PM
What is the proper directory to install libraries/dependecies of Gnome/Anjuta? jdruin Linux - Software 0 12-05-2003 01:20 PM
Anjuta won't build distribution jpbarto Programming 0 06-26-2003 11:56 AM
Build Anjuta 1.0.2 in Slackware 9.0? JoooN Slackware 0 03-31-2003 02:52 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration