LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-23-2004, 01:47 AM   #1
randytsx
LQ Newbie
 
Registered: Dec 2004
Location: Penang, Malaysia
Distribution: Fedora Core 1 and 2, SOT Linux, Linspire, Mandrakelinux 10.1, Damn Small Linux, etc.
Posts: 4

Rep: Reputation: 0
Angry programs won't start, even if they do, they won't run smoothly sometimes, why?


There were many times when I tried to launch a program, like the browser in Linux (using FC2), then I waited for it to load. After a while, the bar on the panel for the browser was gone, but the browser didn't start. Then I tried to launch the browser again, but it just won't start, how to fix this, or prevent this problem? This also happened to many of my programs in Linux.

And sometimes, if a program doesn't run it will just crash, if it doesn't crash then there will be no response, I mean nothing happen, and no programs will be launched. This problem happened at all times randomly in linux, why? Thx to those who helped. :-)

Last edited by randytsx; 12-23-2004 at 01:48 AM.
 
Old 12-23-2004, 01:51 AM   #2
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Slackware64
Posts: 1,704

Rep: Reputation: 76
If a program isn't starting properly then the first thing to do is to try to launch it from the command line and note down any error messages that appear, then post them here.
 
Old 12-23-2004, 01:52 AM   #3
randytsx
LQ Newbie
 
Registered: Dec 2004
Location: Penang, Malaysia
Distribution: Fedora Core 1 and 2, SOT Linux, Linspire, Mandrakelinux 10.1, Damn Small Linux, etc.
Posts: 4

Original Poster
Rep: Reputation: 0
well, there was a time I tried that... and it said "Segmentation fault", what's this?
 
Old 12-23-2004, 01:59 AM   #4
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Slackware64
Posts: 1,704

Rep: Reputation: 76
eek!

Segmentation fault.

No idea to be honest.
 
Old 12-23-2004, 02:19 AM   #5
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
Segfaults can be anything. My guess would be your install is broken. If alot of apps fail then I would reinstall everything. Make sure your cd's are 100%, it's a stable version of the distro and that you don't leave out critical components during install. Sorry I can't give you an easy solution. Segfaults suck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Programs in FluxBox take ages to start or don't start at all hubabuba Slackware 1 02-20-2005 09:21 AM
Cannot run any 3D programs zxt Linux - Distributions 0 07-21-2004 11:32 AM
can't run programs digeratum Linux - Newbie 2 04-10-2004 01:13 PM
Will Fedora + KDE run smoothly? herc Fedora 5 12-27-2003 05:51 PM
So I got my box running smoothly... chingasman Linux - General 3 01-31-2003 01:53 AM


All times are GMT -5. The time now is 03:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration