LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-22-2009, 07:55 AM   #1
yuechun
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
program usring SDL lib run at ARM board, show image speed is very slow.


i use SLD lib to develope a horse run game,at the beginning , i put program run on linux horst , it looks like a game.
then i let it run in arm 9315 board , show on TFT LCD.
screen shows five backgroud photos and five horses, horse run on backgroud.
each backgroud photo's size is 300kb . horse's size is 15kb.
of course arm performance is difference with PC .game Speed looks not very well .

to make backgroud more beatiful ,i add five photos ,each 300kb in backgroud.
all run slowly. then i make backgroud stop moving,they only show in the screen. but horse move slowly all the same. it seems have no realtionship with backgroud move or not, but have to do with photo numbers. of course arm performance is difference with PC .i have check
program , it seems that the photo number that screen once show make the problem. i'm chinese , wish you Happy Christmas.
 
  


Reply

Tags
arm, game, sdl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
when program run at ARM broad, error "couldn't set console screen info" occur yuechun Linux - Software 1 12-16-2009 12:50 PM
Bluetooth on arm board not working mrmuds Linux - Embedded & Single-board computer 0 07-23-2009 03:39 AM
Ultra slow network speed on a p4m80-m4 board beatupbilly Linux - Hardware 5 08-01-2006 06:57 PM
my own tiny SDL program dumps a lot of symbols when it is run kevman Programming 2 03-08-2006 07:05 PM
Trying to program an SDL application but cannot find the SDL.h file:SuSE 9.2&KDevelop pujolasdf Linux - Newbie 4 03-13-2005 08:50 AM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration