LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-04-2004, 05:14 PM   #1
ZingSter
Member
 
Registered: Aug 2004
Location: Northern California
Distribution: SuSE 9.1 Personal; SuSE SLES 9
Posts: 66

Rep: Reputation: 15
Program Launches itself at startup...


Kaffeine launches itself at startup, once the desktop is loaded...How do I turn off this auto launch feature?
I'm using Suse 9.1 personal.
 
Old 10-04-2004, 05:17 PM   #2
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
KDE?

look in
~/.kde/Autostart
 
Old 10-04-2004, 05:54 PM   #3
ZingSter
Member
 
Registered: Aug 2004
Location: Northern California
Distribution: SuSE 9.1 Personal; SuSE SLES 9
Posts: 66

Original Poster
Rep: Reputation: 15
I'm still a newbie...how do I go about locating this file or path?

I'm guessing there is a command of some form that would help to locate say any folder named "autostart"

Can you provide a little more direction?
Thank you.
 
Old 10-04-2004, 06:00 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
there is, indeed
It's called locate :)

locate -i autostart


Cheers,
Tink
 
Old 10-04-2004, 06:05 PM   #5
ZingSter
Member
 
Registered: Aug 2004
Location: Northern California
Distribution: SuSE 9.1 Personal; SuSE SLES 9
Posts: 66

Original Poster
Rep: Reputation: 15
I appreciate your help however the command "locate" is not recognized under SUSE 9.1 personal, I dont think I am doing anything wrong. Any other suggestions?
 
Old 10-04-2004, 06:11 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,004
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
There's
find

Takes a bit longer

find / -iname "autostart"


Cheers,
Tink
 
Old 10-04-2004, 06:19 PM   #7
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
you're not looking to locate it, it should be in ~/.kde/Autostart

now--
from the console|shell|command line (whatever you call that looks like the dos prompt) do this:

Code:
ls -l ~/.kde/
do you see the autostart folder?
-- the tilde (~) refers to your $HOME -- /home/yourname/

also, since the directory '.kde' has a dot in front of it, it will appear hidden on linux... if you want to see it, you have to do:
Code:
ls -la ~
--the 'a' option is for 'all'

are you still with me? what do the commands respond with?
 
Old 10-04-2004, 06:40 PM   #8
ZingSter
Member
 
Registered: Aug 2004
Location: Northern California
Distribution: SuSE 9.1 Personal; SuSE SLES 9
Posts: 66

Original Poster
Rep: Reputation: 15
I understand.
Thanks for your quick responses.

/autostart is empty.
When I execute the command here is what I get:
@linux:~/.kde/Autostart> ls -l ~/.kde/
total 0
drwxr-xr-x 2 johnz users 80 2004-08-13 11:07 Autostart
lrwxrwxrwx 1 johnz users 23 2004-08-13 11:07 cache-linux -> /var/tmp/kdecache-johnz
drwx------ 7 johnz users 168 2004-08-13 11:07 share
lrwxrwxrwx 1 johnz users 18 2004-08-13 11:07 socket-linux -> /tmp/ksocket-johnz
lrwxrwxrwx 1 johnz users 14 2004-08-13 11:07 tmp-linux -> /tmp/kde-johnz

I still cant figure out why Kaffiene continues to launch at the start up.
I've also looked under opt/kde/share/autostart however there is no obvious reference to kaffiene here...
any other ideas ?

Last edited by ZingSter; 10-04-2004 at 06:45 PM.
 
Old 10-04-2004, 06:58 PM   #9
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
(i do not run kaffeine or suse or kde, so i will help as i can, but please bear with me...)
well, i looked up your problem on suse, and you should not feel alone. i found a thread which had a couple good pointers:

Quote:
In SuSE, KDE will by default open the applications that were running the last time you logged out. Kaffeine minimizes to the system tray if you close its window instead of quitting it. Just quit it, log out, and it won't autolaunch when you log back in
...
When ya open kaffeine, check kaffeine settings.
Disable embed in system tray
however, given their problems, it might still run. please let me know if it does, and we'll talk about killing processes.
 
Old 10-04-2004, 07:09 PM   #10
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
Quote:
goto -->kde control center --> kde components -->session manager -->"select" start with an empty session (instead of restore previous session)
 
Old 10-04-2004, 07:16 PM   #11
ZingSter
Member
 
Registered: Aug 2004
Location: Northern California
Distribution: SuSE 9.1 Personal; SuSE SLES 9
Posts: 66

Original Poster
Rep: Reputation: 15
Thank you!
This problem has been solved.
I tried a "ps -e" and found an occurance of kaffiene running. I killed it. Restarted my system and no more kaffeine upon startup. I then went to kde session manager and selected empty session.

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
opera launches on startup cjsmith22 Linux - Newbie 4 05-25-2005 03:51 AM
getting a program to startup Cyric Slackware 4 10-23-2004 07:50 AM
KDE launches unwanted programs at startup crisponions Linux - General 3 05-13-2004 01:57 AM
How to add desktop icon that launches program? registering Linux - Software 3 10-23-2003 05:48 PM
X Startup Program ryanstrayer Linux - General 1 01-29-2002 04:21 PM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration