LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-17-2003, 10:41 AM   #1
nutz
LQ Newbie
 
Registered: Nov 2003
Location: Finland
Distribution: Debian
Posts: 15

Rep: Reputation: 0
Program installing problem


When I try to install program rom rpm package with Kpackage, installing stops and it says "/bin/sh is needed by [program name]"
 
Old 11-19-2003, 05:36 AM   #2
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Do you have /bin/sh?
 
Old 11-19-2003, 09:20 AM   #3
nutz
LQ Newbie
 
Registered: Nov 2003
Location: Finland
Distribution: Debian
Posts: 15

Original Poster
Rep: Reputation: 0
Yes, but it's probably broken, I think. I should get new file.
 
Old 11-19-2003, 09:34 AM   #4
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
What happens if you use rpm from the command line?
rpm -i packagename.rpm
 
Old 11-20-2003, 02:20 PM   #5
nutz
LQ Newbie
 
Registered: Nov 2003
Location: Finland
Distribution: Debian
Posts: 15

Original Poster
Rep: Reputation: 0
I tried it with Opera's rpm package as you can see.

error: failed dependencies:
/bin/sh is needed by opera-7.22-20031103.2
ld-linux.so.2 is needed by opera-7.22-20031103.2
libICE.so.6 is needed by opera-7.22-20031103.2
libSM.so.6 is needed by opera-7.22-20031103.2
libX11.so.6 is needed by opera-7.22-20031103.2
libXext.so.6 is needed by opera-7.22-20031103.2
libXt.so.6 is needed by opera-7.22-20031103.2
libc.so.6 is needed by opera-7.22-20031103.2
libdl.so.2 is needed by opera-7.22-20031103.2
libm.so.6 is needed by opera-7.22-20031103.2
libpthread.so.0 is needed by opera-7.22-20031103.2
libqt.so.3 is needed by opera-7.22-20031103.2
libc.so.6(GLIBC_2.0) is needed by opera-7.22-20031103.2
libc.so.6(GLIBC_2.1) is needed by opera-7.22-20031103.2
libdl.so.2(GLIBC_2.0) is needed by opera-7.22-20031103.2
libdl.so.2(GLIBC_2.1) is needed by opera-7.22-20031103.2
libm.so.6(GLIBC_2.0) is needed by opera-7.22-20031103.2
libpthread.so.0(GLIBC_2.0) is needed by opera-7.22-20031103.2
libpthread.so.0(GLIBC_2.1) is needed by opera-7.22-20031103.2
 
Old 11-23-2003, 07:23 PM   #6
davoman
Member
 
Registered: Nov 2003
Location: New Zealand
Distribution: Ubuntu 6.10/7.04
Posts: 51

Rep: Reputation: 15
I get the same thing while trying to install Tux Racer. And I KNOW I have those files in my /lib and /usr/lib directories. Is there some way of telling rpm/kpackage where the hell the files are? (Extreme newbie alert).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing a KDE program Einar Magnus Linux - Software 4 10-12-2004 04:20 AM
Installing a Program? snoopyswiss Linux - Newbie 2 08-18-2004 07:23 AM
Installing a program newuser455 Linux - Hardware 3 05-23-2004 09:46 PM
problem while installing p2p program Par4n0iA Linux - Software 2 08-10-2003 08:30 AM
problem installing downloaded program shoot2kill Linux - Software 2 05-24-2002 03:07 PM


All times are GMT -5. The time now is 09:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration