LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-03-2003, 04:20 PM   #1
BlackRabbit
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 83

Rep: Reputation: 15
Proftpd + softlinks + no go?


Hello,

until now I used a temporary setup where I mounted all my harddisks at /data/everyone/[somedir] with "/data/everyone" being the Proftp "root" when logged in..
This setup worked, but since Games, Series and Albumz were stored in "Stuff" (e.g. mount /dev/hdc1 /data/everyone/Stuff), it was'n very clear what was inside the "stuff" directory.

So I desided to use softlinks:


I divided the various files over various disks:
hdb1 = games + applications
hdc1 = movies
hdd1 = Series + albumz

Wrote me a little script:


--------------------------------------------------------------------------------
#! /bin/bash
#
mount /dev/hdb1 /tmp/hdb1
mount /dev/hdc1 /tmp/hdc1
mount /dev/hdd1 /tmp/hdd1
#softlinks (FTP => /data/everyone)
ln -s /tmp/hdb1/Series /data/everyone/Series
ln -s /tmp/hdb1/Albumz /data/everyone/Albumz
ln -s /tmp/hdb1/Mp3 /data/everyone/Mp3

ln -s /tmp/hdc1/Movies /data/everyone/Movies

ln -s /tmp/hdd1/Games /data/everyone/Games
ln -s /tmp/hdd1/Applications /data/everyone/Applications

--------------------------------------------------------------------------------

I tested on the server with cd if I could get to see the files,and I could.
Now I logged in to the FTP, saw the list of (what appears to be) directories and tried to enter 1 of the dirs:

550: "no such file or directory"


Tried several kinds of softlinks, but it never worked.. Is it possible that I cannot use softlinks when FTPing? (When cd'ing through sshd, it works..)


Thanks!


PS: SlackWare 9.1 BTW

Last edited by BlackRabbit; 12-03-2003 at 04:46 PM.
 
Old 12-03-2003, 04:36 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,999
Blog Entries: 11

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
Have a look at
/<where ever RH puts docs>/proftpd<version-mumble>/doc/Configuration.html

Supposedly there's a few settings in the
respect of handling links.



Cheers,
Tink
 
Old 12-03-2003, 05:02 PM   #3
BlackRabbit
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 83

Original Poster
Rep: Reputation: 15
Quote:
Compatibility: 0.99.0pl6 and later Symbolic links (if supported on the host OS and filesystem) can be either shown in directory listings (including the target of the link) or can be "hidden" (proftpd dereferences symlinks and reports the target's permissions and ownership). The default behavior is to show all symbolic links when normal users are logged in, and hide them for anonymous sessions. If a symbolic link cannot be dereferenced for any reason (permissions, target does not exist, etc) and ShowSymlinks is off, proftpd displays the link as a directory entry of type 'l' (link) with the ownership and permissions of the actual link. Under ProFTPD versions 1.1.5 and higher, the default behavior in regard to ShowSymlinks has been changed so that symbolic links are always displayed as such (in all cases), unless ShowSymlinks off is explicitly set.
Tried on/off
off => no softlinks (dirs invisible)
on => visible, but not enterable (problems stays)

The directories do say "l"..



MOD: and is it normal I cannot chmod a softlink?

Last edited by BlackRabbit; 12-03-2003 at 05:04 PM.
 
Old 12-03-2003, 05:11 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,999
Blog Entries: 11

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
Quote:
Originally posted by BlackRabbit
MOD: and is it normal I cannot chmod a softlink?
Yep.


Cheers,
Tink
 
Old 12-03-2003, 05:40 PM   #5
BlackRabbit
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 83

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Tinkster
Yep.


Cheers,
Tink
Thanks

(but I still don't know what to do )
 
Old 12-04-2003, 05:20 AM   #6
BlackRabbit
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 83

Original Poster
Rep: Reputation: 15
So if I understand correctly, it should work with the currect settings?

Then why can't I enter the directory the softlink is targetting at?
I do have r+x rights to the target...
 
Old 12-16-2003, 09:20 AM   #7
BlackRabbit
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 83

Original Poster
Rep: Reputation: 15
It's still not working..

This is my configfile, maybe you guys see something I don't see..

Code:
ServerName                      "Datanuke FTP Server"
Port                            21
ServerType                      standalone
DeferWelcome                    off


# FXP
AllowForeignAddress     on
#AllowLogSymlinks               on #on/off doesn't make a difference here
ShowSymlinks                    on #off => dirs(symlinks) are not shown; on => shown, but inaccesible
MultilineRFC2228                on

DefaultServer                   on
AllowOverwrite                  on
AllowRetrieveRestart            on
AllowStoreRestart               on

MaxClientsPerHost               2
TimeoutNoTransfer               600
TimeoutStalled                  600
TimeoutIdle                     1200

DisplayLogin                    motd
DisplayFirstChdir               .message
ListOptions                     "-l" # don't know what options I can add here
DefaultRoot                     ~

DenyFilter                      \*.*/

RequireValidShell               off
MaxInstances                    20

User                            nobody
Group                           nogroup
UserAlias                       datanuke nobody

<Directory /*>
  Umask                         022  022
  AllowOverwrite                on
</Directory>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Softlinks - cannot delete dajomu Red Hat 4 08-17-2005 03:36 PM
Crappy softlinks dajomu Linux - Newbie 4 08-16-2005 04:50 PM
[PROFTPD] Ldap and proftpd authentication wesleywest Linux - Software 1 02-22-2005 10:51 AM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 11:27 AM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 07:56 PM


All times are GMT -5. The time now is 08:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration