LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-10-2003, 08:20 PM   #1
Vampyric
LQ Newbie
 
Registered: Mar 2003
Posts: 27

Rep: Reputation: 15
Proftpd problems when moved off default port 21


This problems seems kinda strange and have been unable to find the problem.

Proftpd has been up and running, stable, with no problems EXCEPT if I change the port to anything other than 21.

If changed this is what happens

connected
[server name stuff]
[username stuff]
[password stuff]
connection successfull !!!

So everything logged in a-okay.... BUT if you ...... for example

ftp> ls
PORT COMMAND SUCCESSFULL


and that's it... it just hangs there and never lists.
I don't get anything in the log file either for a possible problem.
I've looked over the config file countless times as well have tried webmin as a more user friendly config tool.

Any ideas on why it would respond to 21 the way it's supposed to but act weird on any other ??

(note: I use iptables... it is not blocking pasv ranges or the port I'm setting it too so firewall is not the problem)
 
Old 12-12-2003, 05:41 PM   #2
excel28
Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 72

Rep: Reputation: 15
Hey, I had the same problem a couple months ago. But it works fine without port 21. It has to do something with passive ports. And if you're behind a firewall (I have a hardware firewall) then you have to set that port to be open and forward that port to that specific computer.

I currently ain't on that computer right now, but when I get a change, I'll look at my config file and stuff and reply again.
 
Old 12-13-2003, 04:26 PM   #3
Vampyric
LQ Newbie
 
Registered: Mar 2003
Posts: 27

Original Poster
Rep: Reputation: 15
thanx.

still haven't figured out the stupid problem yet
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PLESK [Solution] Change port to 23 (telnet) instead of default port 8443 x5452 Linux - Software 6 05-10-2009 06:58 AM
Proftpd and port forwarding not working mmcampbe Linux - Software 1 09-15-2005 03:38 PM
just moved to uni - proxy problems on Slackware 10! darksmiley Linux - Networking 12 09-29-2004 06:28 PM
proftpd : PORT command unsuccesful shyam_d_sundar Linux - Software 0 06-13-2004 11:19 PM
Moved W2k(hda) to new computer, now Gentoo(hdb) problems jrperiod Linux - Newbie 6 04-15-2004 08:45 AM


All times are GMT -5. The time now is 08:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration