LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-06-2006, 02:43 PM   #1
richardhufford
LQ Newbie
 
Registered: May 2006
Location: Safford, AZ, USA
Distribution: Ubuntu 11.04
Posts: 15
Blog Entries: 1

Rep: Reputation: 0
procmail not producing mbox format


I am trying to process and reroute some email, using fetchmail to get the email from our ISP, procmail to route it to different mailboxes, and dovecot-imapd to serve the email to our users. The problem is that I cannot access the email from another computer (with Outloook Express). In the log /var/log/mail.log, I get a message that the file routed by procmail
/var/mail/richard is not in mbox format, so the INBOX can't be read.
I manually edited the mailbox file /var/mail/richard, and added the line From to the top of the file, and the message was then handled correctly by the IMAP server. How do I get procmail to include the From line?

fetchmail calls procmail with
-moY /etc/procmailrcs/rc.testing

rc.testing contains this rule for now:
:0:
/var/mail/richard

# EOF

I am running Debian Sarge (2.4 might be the version), procmail v3.22, and dovecot v0.99.14
 
Old 12-06-2006, 04:52 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi

Run procmail with the '-f someone@somewhere' arg.

Dave
 
Old 12-06-2006, 04:55 PM   #3
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,374
Blog Entries: 54

Rep: Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872Reputation: 2872
How do I get procmail to include the From line?
I'd say it's not Procmail, but Fetchmail: check your conf for the line "no rewrite". If not there, add it and test.
 
Old 12-06-2006, 09:00 PM   #4
richardhufford
LQ Newbie
 
Registered: May 2006
Location: Safford, AZ, USA
Distribution: Ubuntu 11.04
Posts: 15
Blog Entries: 1

Original Poster
Rep: Reputation: 0
It was the -f option. I entered
-f -
into the procmail command line. Thank you very much. I've been looking at this for days!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sendmail producing messages in maillog lawadm1 Linux - Software 1 12-09-2005 04:28 PM
mp3record producing soundless files nazarioz Linux - Newbie 5 06-12-2005 09:13 PM
Webalizer not producing reports Braytac Linux - Networking 1 04-22-2005 04:04 PM
Audio apps for producing libranikki General 12 02-16-2005 02:13 PM
mbox format raven Programming 0 02-16-2002 06:10 AM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration