LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-11-2003, 06:01 AM   #1
Tusnal
LQ Newbie
 
Registered: Feb 2003
Location: For Now Spain
Distribution: RH 9
Posts: 11

Rep: Reputation: 0
problems with X and resolutions


hi i got some problems with the resolutions....... i use RH9 and i installed a new graphic card some geforce4 mx se 128mb and then ....... when i try to go to the x it just gives me 800x600 and that sux!!!!

well i tried to put it to another one like 1024x768 and nothing i restard X and it gives me 800x600 :S weird!!!! i modify the XF86Config manually and put it there "1024x768" and when i try to go to gdm it gimmes a error and i cant see the X windows so????

some help plz!! thx

Tusnal
 
Old 05-11-2003, 06:02 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Did you install the Nvidia drivers for Linux from www.nvidia.com ?

Follow the README associated with your driver file and edit your XF86Config accordingly.

Cool
 
Old 05-14-2003, 09:25 AM   #3
Tusnal
LQ Newbie
 
Registered: Feb 2003
Location: For Now Spain
Distribution: RH 9
Posts: 11

Original Poster
Rep: Reputation: 0
hmmmmmmmmm still getting the same problem when i try to go in 1024x768 it doesnt show up and gieves me errors like this:

(EE) NVIDIA(0) no modes remaining for display CRT-0
aborting

so i dunno what happend :S what can i do??
 
Old 05-14-2003, 09:47 AM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Can you post up your XF86Config-4 file? That will help us in diagnosing your problem

Cool
 
Old 05-15-2003, 05:27 AM   #5
Tusnal
LQ Newbie
 
Registered: Feb 2003
Location: For Now Spain
Distribution: RH 9
Posts: 11

Original Poster
Rep: Reputation: 0
well i am using RH9 for now and it doenst use XF86Config-4 it use XFree86Config without the (-4) dunno why but it does!!!! anyway in this web is the XF86Config and XFree86.0.log for the problem

http://www.geocities.com/tusnal/tmp/XFree86.0.log
http://www.geocities.com/tusnal/tmp/XF86Config.txt

thx for the help.
Tusnal
 
Old 05-15-2003, 05:49 AM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
The Screens sections defines the resolution you are running at. The first entry determines "default". So:
Code:
Section "Screen"
	Identifier "Screen AGP"
	Device     "NV AGP"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Depth     16
		Modes    "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1280x900" "1024x768" 
	EndSubSection
Change:
Code:
SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1280x900" "1024x768" 
	EndSubSection
to
Code:
SubSection "Display"
		Depth     24
		Modes     "1024x768" "1280x1024" "1280x900" 
	EndSubSection
Since your default depth is defined as "24" that's the entry you should be editing.

Cool
 
Old 05-15-2003, 05:56 AM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Also, just reading over the Config file again, it looks wrong...

Try editing this section:
Code:
Section "ServerLayout"
	Identifier     "AGP"
	Screen         "Screen AGP"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "DevInputMice" "AlwaysCore"
EndSection
to this:
Code:
Section "ServerLayout"
	Device     "NV AGP"
	Screen         "Screen AGP"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "DevInputMice" "AlwaysCore"
EndSection
OR
Code:
Section "ServerLayout"
	Identifier     "NV AGP"
	Screen         "Screen AGP"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "DevInputMice" "AlwaysCore"
EndSection
I am not sure which one, but the original just doesn't look right.

Cool
 
Old 05-15-2003, 11:12 AM   #8
Tusnal
LQ Newbie
 
Registered: Feb 2003
Location: For Now Spain
Distribution: RH 9
Posts: 11

Original Poster
Rep: Reputation: 0
ok i will try the that NV APG but the 24 display is ok cuz i edited it to much times and still crashed...... some times i just put:

SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection

and doesnt work so i just gonna try that NV AGP and see what happend ok

thx. Tusnal
 
Old 05-15-2003, 06:42 PM   #9
davecs
Member
 
Registered: Feb 2003
Location: Dagenham, Essex, Britain
Distribution: PCLinuxOS
Posts: 485

Rep: Reputation: 31
I think your problem may lie here:

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
>> HorizSync 31.5 - 37.9
>> VertRefresh 50.0 - 70.0

Do you have a Windows dual boot? If so, run your monitor at the desired resolution in Windows, press the menu button on the front of your monitor, and check the Vertical Refresh and Horizontal Sync Rates. For example my monitor runs at 1280x1024 and the Vertical Rate is 75.3Hz, the Horizontal Refresh is 80.3kHz. As you can see, both my figures are outside the range defined in your XF86Config file. In fact your XF86Config file is restricting your monitor to ridiculously low refresh rates. This is what happens when your monitor is not listed and you pick a generic one.

I had a problem with picture instability, so I increased my upper figures on the HorizSync and VertRefresh lines to 81 and 76 respectively and now Linux uses the same rates as Windows and all is well.

If you don't have Windows do you know the claimed figures for your monitor. For example if your monitor is capable of 75Hz, your XF86Config file is restricting it to 70 max, which in effect is 60Hz. Worse, if like my monitor, the Horizontal rate for 60Hz is 64kHz, then your XF86Config file has ruled this out altogether so the system will not be able to run the monitor for you.

It has nothing to do with installing the nVidia drivers: all they do is enable 3D OpenGL mode and improve 2D a bit, but they will not override this setting.

If you do not have a Windows dual boot, you will have to increase the upper limits. However I suspect that with Generic monitors, the defaults are low for a good reason: you don't want your monitor fried! Perhaps you can get the data from the manufacturer. If not, perhaps you can increase the rate in small steps until something works, keeping your fingers crossed as you go!

DAVE
 
Old 05-15-2003, 06:59 PM   #10
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Rep: Reputation: 30
Well,
Its a simple problem; I got it when i installed RH9. All youneed to do is to change your monitor type to

SVGA 1024x 786 @ 70 Hz

and it works perfectly

Hope that helps...
 
Old 05-16-2003, 04:38 AM   #11
Tusnal
LQ Newbie
 
Registered: Feb 2003
Location: For Now Spain
Distribution: RH 9
Posts: 11

Original Poster
Rep: Reputation: 0
well about the dual boot yeah i am using XP too and i installed some refreshtool to make it up to 100.

i got in the windows 1024x768 Hz 100 sorry but i got the windows xp in spanish and when i do right click to the desktop and go to monitor it say "frecuency of refresh or something like that!!! " is 100 Hercios and maybe ... that is problem.

i put some new f86conf here http://www.geocities.com/tusnal/tmp/XF86Config.txt

i dunno what is the problem it is let me go to X i just can see the X in 800x600 i just cant get it!!!!!

Tusnal
 
Old 05-16-2003, 04:40 AM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
The refresh rate that he is referring to is given by your monitor, not windows. Windows is just the other operating system that you'll go into so your monitor is using the frequency you desire. Then you take that and edit your XF86Config file to show that frequency.

Cool
 
Old 05-18-2003, 08:43 AM   #13
davecs
Member
 
Registered: Feb 2003
Location: Dagenham, Essex, Britain
Distribution: PCLinuxOS
Posts: 485

Rep: Reputation: 31
Sorry Tusnal what I meant was you go into Windows and switch to your favourite resolution. Then you press the button ON YOUR MONITOR and you normally get an on-screen menu, and have to select from a number of options. The one that works for me is a logo with a letter "i" in the middle. When I select that on mine I get a reading which says 80.3kHz 75.3Hz. The one which says Hz is your Vertical refresh rate and the one which says kHz is your Horizontal sync.

Hope that's helpful.

DAVE
 
Old 05-24-2003, 06:36 AM   #14
Tusnal
LQ Newbie
 
Registered: Feb 2003
Location: For Now Spain
Distribution: RH 9
Posts: 11

Original Poster
Rep: Reputation: 0
well i got it working finally i just try everything .... and well the Xf86 file is the same like the old one and it works i just changed the monitor to the SVGA and it works thx all u guys!!!

Tusnal
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Resolutions,Sizes,everything starfly Linux - Laptop and Netbook 4 04-13-2005 12:20 AM
Help with monitor resolutions! cereal83 Slackware 24 02-27-2005 10:10 PM
Resolutions linuxmdknew Mandriva 1 11-05-2004 06:49 PM
two resolutions the_big_frog Slackware 1 08-03-2003 03:46 PM
Resolutions Steppenwolf Linux - Newbie 4 04-25-2003 01:35 AM


All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration