LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-01-2002, 02:48 AM   #1
X11
Member
 
Registered: Dec 2001
Location: Brisie, Australia
Distribution: Slackware 8.1
Posts: 324

Rep: Reputation: 30
Problems with Proftpd


I'm trying to setup a private FTP Server on a LAN at home. But I seem to have problem getting Proftpd working properly: I've checked the file called proftpd.conf in the /etc directory and have compared it to some sample configuration files I've downloaded Proftpd's web site.

BTW: Here's the setup; I have two machines (with no firewall enabled) connected to each other via a Layer 2 Ethernet Switch (This switch does not have firewalling capabilities BTW).

I've done a ping test from both machines and they both work A-OK. But went I try to ftp to the machine with proftpd on it, it doesn't work.

Here's what typed in from the client-side:
Quote:
ftp 192.168.100.1
And here's the error/message that it "spat out""
Quote:
Connected to 192.168.100.1.
421 Service not available, remote server has closed connection
BTW: I have typed in proftpd at the console of where I want to run the FTP server from.

Thanks very much, X11.

Last edited by X11; 08-01-2002 at 02:50 AM.
 
Old 08-01-2002, 02:49 AM   #2
X11
Member
 
Registered: Dec 2001
Location: Brisie, Australia
Distribution: Slackware 8.1
Posts: 324

Original Poster
Rep: Reputation: 30
Post BTW, here's a copy of my proftpd.conf file

# This is a basic ProFTPD configuration file.
# It establishes a single server and a single anonymous login.
# It assumes that you have a user/group "nobody" and "ftp"
# for normal/anonymous operation.

ServerName "FTP"
ServerType standalone
#ServerType inetd
DefaultServer on

# Port 21 is the standard FTP port.
Port 21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 30

# Set the user and group that the server normally runs at.
User ftp
Group ftp

# This next option is required for NIS or NIS+ to work properly:
#PersistentPasswd off

SystemLog /var/log/proftpd.log
TransferLog /var/log/xferlog

# Normally, we want files to be overwriteable.
<Directory /*>
AllowOverwrite on
</Directory>

# A basic anonymous FTP server configuration.
# To enable this, remove the user ftp from /etc/ftpusers.
<Anonymous ~ftp>
RequireValidShell off
User ftp
Group ftp
# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
MaxClients 5

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>

# An upload directory that allows storing files but not retrieving
# or creating directories.
# <Directory incoming/*>
# <Limit READ>
# DenyAll
# </Limit>
#
# <Limit STOR>
# AllowAll
# </Limit>
# </Directory>

</Anonymous>
 
Old 08-01-2002, 03:58 AM   #3
lopezjo49
Member
 
Registered: Jun 2002
Location: NJ
Distribution: Mainly Kubuntu 8.10
Posts: 44

Rep: Reputation: 15
Are you sure ftp is running on the server? Try using nmap to see if port 21 shows up 'nmap localhost'.

If not you need to start ftp properly depending on what your running it on. The servers in.* usually need to be run as root.

If you're using RedHat with xinetd make sure /etc/xinetd.d/proftp file has "disable no" and restart xinted by running '/etc/init.d/xinetd restart. Then if you tail /var/log/messages you should see that it started and there is 1 new service.

If it's initiated from the older /etc/inetd.conf you'll need:
"ftp stream tcp nowait root /usr/sbin/tcpd in.proftpd"
then restarted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd problems soulwatcher1974 Linux - Software 4 06-04-2005 11:01 PM
proftpd problems mindfestival Linux - Newbie 7 08-16-2004 08:18 AM
Problems with proftpd alitrix Linux - Software 0 12-13-2003 04:58 AM
Problems with Proftpd Inexactitude Linux - Networking 4 11-21-2003 07:12 PM
ProFTPD problems Corellon Linux - Newbie 23 06-07-2003 11:11 AM


All times are GMT -5. The time now is 12:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration