LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-06-2003, 07:12 AM   #1
lub0
Member
 
Registered: Aug 2003
Location: Glasgow Scotland
Posts: 92

Rep: Reputation: 15
Problems with Nvidia driver....!


Hi All,

I recently downloaded the most up2date driver from nvidia for my graphics card, and to be truthful I think its worse. I run RH8 and have GeForce2 gts ( hercules or something ) 32MB. It is a fairly decent card and in windoze it works excellent, so I am guessing I screwed up somewhere along the line when i installed the driver. I tried the command mentioned above and here is the output:

[root@localhost rpm]# glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 16 tc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 16 dc 0 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

I am still fairly new to Linux, but that is screaming out to me, HELP!

Can anyone help me on this.....

Thanks in Advance...


lub0
 
Old 10-07-2003, 12:59 AM   #2
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Slackware64
Posts: 1,703

Rep: Reputation: 76
check that there isn't a # in front of the "load GLX" line in the XF86Config file
 
Old 10-07-2003, 09:03 AM   #3
lub0
Member
 
Registered: Aug 2003
Location: Glasgow Scotland
Posts: 92

Original Poster
Rep: Reputation: 15
Here is a copy of my /etc/X11/XF86Config

# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "dri"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc101"
Option "XkbLayout" "gb" #Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 30.0 - 107.0
VertRefresh 50.0 - 200.0
Option "dpms"
EndSection

Section "Device"
# no known options
#BusID
Identifier "NVIDIA GeForce 2 GTS (generic)"
Driver "nv"
VendorName "NVIDIA GeForce 2 GTS (generic)"
BoardName "NVIDIA GeForce 2 GTS (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 2 GTS (generic)"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

the "glx" module appears to be loaded ( if this is the right file )

Thanks i advance..


lub0
 
Old 10-07-2003, 09:38 AM   #4
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
well judging by that you didn't follow instructions very well when you installed you nvidia driver...
Driver "nv" is supposed to be :: Driver "nvidia"
and you have to remove the line
Load "dri" or just comment it out by putting a pound sign (#) in front of it like :: #Load "dri"
 
Old 10-07-2003, 09:48 AM   #5
lub0
Member
 
Registered: Aug 2003
Location: Glasgow Scotland
Posts: 92

Original Poster
Rep: Reputation: 15
Thanks man I will give it a go, am new to this. I was born and bred ( &corrupted) on windoze. Where they hold your hand for you and tell you it's ooook. lol


thanks Dr0zz

lub0
 
Old 10-07-2003, 10:12 AM   #6
lub0
Member
 
Registered: Aug 2003
Location: Glasgow Scotland
Posts: 92

Original Poster
Rep: Reputation: 15
XServer refused to start

Hi Dr0zz,

Well it appears you were dead right, not only did I incorrectly install the driver it appears its does not even exist. I tried what you said and edited the /etc/X11/XF86Config file, but when i rebooted it failed to start X and ended up "trying fresh configuration" in which it resorted back to the old XF86Config file. With some changes :

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

When I installed the driver I printed out the instructions and followed them word by word have you got way in which i can try it again. Any help is much appreciated.


lub0
 
Old 10-07-2003, 11:42 PM   #7
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Post

Make sure x is not running. One way to do this is to open a term and get root access and type in "init 3". Don't panic. The GUI will disappear rather rudely. When you get to command line just CD to where the driver is and install. I usually put it in the root directory. Easy to find there.

When you get it installed, just type in "init 5". The services will start back up and x will load. You can use kwrite to change the driver to nvidia if you want. Just log out and back in. Should see the white screen with NVIDIA then. You can then go real big.

Hope that helps.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver problems Avatar33 Linux - Newbie 13 03-14-2005 09:29 AM
nvidia instalation problems / Sblive driver problems Colonel-1990 Linux - Software 13 02-14-2005 05:48 PM
nvidia driver problems novacrasher Linux - Hardware 4 12-10-2004 05:07 PM
Problems with 9.2 and Nvidia driver jriis Mandriva 3 11-24-2003 10:33 PM
nvidia Driver problems cappaccio Linux - Hardware 16 05-05-2003 01:47 PM


All times are GMT -5. The time now is 02:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration