LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problems with libstdc versions 5 and 6 (http://www.linuxquestions.org/questions/linux-software-2/problems-with-libstdc-versions-5-and-6-a-441208/)

mainemike 05-03-2006 07:08 AM

Problems with libstdc versions 5 and 6
 
I am in the process of installing a program that requires libstdc++.so.5. I currently have libstdc++.so.6 and very many dependancies.

The first thing I tried was to link so.5 to so.6.0.6. It allowed the install to progress, but the application won't run because it is looking for `GLIBCPP_3.2'and `CXXABI_1.2' which aren't in so.6.0.6.

I then downloaded libstdc++-3.3.5-5.i586.rpm for my distribution (SuSE 10). When I run 'rpm -ivh libstdc++-3.3.5-5.i586.rpm --nodeps', it get..

hostname:/home/user/downloads # rpm -ivh libstdc++-3.3.5-5.i586.rpm --nodeps
Preparing... ########################################### [100%]
package libstdc++-4.0.2_20050901-3 (which is newer than libstdc++-3.3.5-5) is already installed

So I am assuming that I need both versions. Is this correct? If so, how to I get bot libs installed without my system complaining?

berbae 05-03-2006 08:42 AM

Hi
you must install the compat-libstdc++ package for OpenSuSE :
rpm file for i586
This should install the required libstdc++.so.5 library for compatibility with other packages.
After the installation run under root :
ldconfig
to enable the use of the shared libraries.


All times are GMT -5. The time now is 01:03 AM.