LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-11-2006, 11:11 AM   #1
priceey
LQ Newbie
 
Registered: Mar 2006
Posts: 13

Rep: Reputation: 0
Unhappy problems with installing exim with DB4.4.20


Hello there

i am a newbie when it comes to linux, and i seem to be in a spot of bother...

i am trying to install Exim 4.4 n my Fedora box.

i have installed Berekely db.4.4.20 on it, and the makefile for exim has a reference in it for a lib stored there.

when i try to make exim this happends:

gcc -o exim_dbmbuild
/usr/local/BerkeleyDB.4.4/lib/libdb.a(mut_pthread.o)(.text+0xcc): In function `__db_pthread_mutex_init':
mut_pthread.c: undefined reference to `pthread_mutexattr_init'
/usr/local/BerkeleyDB.4.4/lib/libdb.a(mut_pthread.o)(.text+0xf1):mut_pthread.c: undefined reference to `pthread_mutexattr_destroy'
/usr/local/BerkeleyDB.4.4/lib/libdb.a(mut_pthread.o)(.text+0x10b):mut_pthread.c: undefined reference to `pthread_mutexattr_setpshared'
/usr/local/BerkeleyDB.4.4/lib/libdb.a(mut_pthread.o)(.text+0x14c):mut_pthread.c: undefined reference to `pthread_condattr_setpshared'
collect2: ld returned 1 exit status
make[1]: *** [exim_dbmbuild] Error 1
make[1]: Leaving directory `/usr/src/mail-sources/exim-4.60/build-Linux-athlon'
make: *** [go] Error 2

i am trying to get exim to link to lpthread but i have reached a brick wall and really dont know what to do next. any help would be appriciated!!!

Priccy
 
Old 03-11-2006, 04:41 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
Quote:
gcc -o exim_dbmbuild
that don't seem like the whole command
we need the whole thing

but basically that line (should we be able to see it) needs -lpthread at the end of it

should be able to add it in the Makefile somewhere or just copy paste the fixed command on the command line

Last edited by foo_bar_foo; 03-11-2006 at 04:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
email/Exim Problems bassfreq Debian 1 04-02-2005 02:49 PM
Installing using debootstrap -> exim error? ohman Debian 1 09-19-2004 09:00 PM
exim is failed !!! error:package exim is not installed apache Linux - Software 0 06-24-2004 05:55 AM
Exim/spamassassin problems tensigh Linux - Software 1 04-27-2004 05:01 AM
exim problems ! help please ! Mr.Bingles Debian 1 12-01-2003 07:11 AM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration