LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problems with Gnome Do in Gnome 3/Gnome shell (http://www.linuxquestions.org/questions/linux-software-2/problems-with-gnome-do-in-gnome-3-gnome-shell-884224/)

alecjtaylor 06-02-2011 06:42 PM

Problems with Gnome Do in Gnome 3/Gnome shell
 
Hi all,

I've just installed Gnome 3/Gnome shell on Ubuntu 11.04 after Unity made drove me to distraction. I'm really liking the idea of Gnome 3, but Gnome Do is buggy and slow. I've changed the call key strokes for Gnome Do to make sure it doesn't clash with any Gnome 3 commands but it still is really bad. Has anyone else had any success/failure with Gnome do and Gnome 3?

Thanks

Alec

p.s. sorry repeating the word Gnome 20 times in the question!

jakethedog 09-12-2011 02:58 AM

I guess gnome 3 is the problem, because on my other Ubuntu Computer I had both Gnome-Do and Docky and it always worked fine.

alefq 11-27-2011 09:04 AM

Also a problem in Linux Mint 12 (Lisa)
 
It looks that
- the only way of setting shortcuts is through the "Settings/Keyboard" from gnome 3 menu.
- No shortcut could contain the Meta/Win key

I've found a workaround,
1)Go to Settings/Keyboard/Shortcuts
2)Create a new item under Custom Shortcuts, with the "+" icon
3) Name it "gnome-do" and put as command also "gnome-do"
4) Assign a new accelerator key, clicking on the "Disabled" beside "gnome-do". The key combination should not contain the Meta/Win key. I'm using Ctrl+Space

I hope that helps.




Quote:

Originally Posted by alecjtaylor (Post 4374528)
Hi all,

I've just installed Gnome 3/Gnome shell on Ubuntu 11.04 after Unity made drove me to distraction. I'm really liking the idea of Gnome 3, but Gnome Do is buggy and slow. I've changed the call key strokes for Gnome Do to make sure it doesn't clash with any Gnome 3 commands but it still is really bad. Has anyone else had any success/failure with Gnome do and Gnome 3?

Thanks

Alec

p.s. sorry repeating the word Gnome 20 times in the question!


alefq 11-30-2011 08:51 PM

I had to disable the shortcut, because every CTRL key press during typing, triggered gnome-do's shortcut, even when there wasn't the combination pressed. :(


Quote:

Originally Posted by alefq (Post 4535195)
It looks that
- the only way of setting shortcuts is through the "Settings/Keyboard" from gnome 3 menu.
- No shortcut could contain the Meta/Win key

I've found a workaround,
1)Go to Settings/Keyboard/Shortcuts
2)Create a new item under Custom Shortcuts, with the "+" icon
3) Name it "gnome-do" and put as command also "gnome-do"
4) Assign a new accelerator key, clicking on the "Disabled" beside "gnome-do". The key combination should not contain the Meta/Win key. I'm using Ctrl+Space

I hope that helps.



All times are GMT -5. The time now is 09:32 PM.