Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 09-20-2004, 01:56 PM   #1
LQ Newbie
Registered: Sep 2004
Posts: 1

Rep: Reputation: 0
problems with apache-1.3.33 php 5

i recently installed Apache 1.3.33 with MySQL-4.0.21-mod_ssl-mod_perl-openssl-mod_php-PHP5 and i am having issues with php and Apache.
First of all apache cannot seem to locate any files i place in the htdocs folder. I get the object not found error page when i try to access the file

i am also have a problem with Firefox 0.9.3 and viewing PHP scripts. the OPEN dlg box pops up and i select to open with mozilla and push ok and then the same dlg box comes up again repeatedly.
Configure Apache
EAPI_MM="/usr/local/mm-1.2.2" SSL_BASE="/usr/local/ssl" \
./configure \
--enable-module=unique_id \
--enable-module=rewrite \
--enable-module=speling \
--enable-module=expires \
--enable-module=info \
--enable-module=log_agent \
--enable-module=log_referer \
--enable-module=usertrack \
--enable-module=proxy \
--enable-module=userdir \
--enable-module=so \
--enable-shared=ssl \
--enable-module=ssl \
--activate-module=src/modules/perl/libperl.a \
This is how i configured PHP
./configure --with-apxs=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql --with-pgsql=/usr/local/pgsql --enable-track-vars --with-openssl=/usr/local/ssl --with-imap=/usr/local/imap --with-gd --with-ldap --enable-ftp --enable-sysvsem --enable-sysvshm --enable-sockets --with-pdflib=/usr/local --with-gettext --with-mm=/usr/local/mm-1.2.2 --with-jpeg-dir=/usr/lib --with-zlib-dir=/usr/local --enable-wddx --with-mcrypt --with-mhash --with-mcal=/usr --enable-exif --enable-xslt --with-xslt-sablot=/usr/local --with-dom --with-dom-xslt --with-kerberos

make install

I documented every step of the websrvr install so if any other detailed are req'd plz tell me

thank you very much for any help


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache 1.3.33 + PHP 5.02 problems... NuTBoMbS Linux - Software 1 11-09-2004 02:36 AM
slackware, apache and PHP from .tgz - problems with PHP szymon Slackware 2 09-06-2004 05:57 PM
Apache and Php problems myguest Linux - Software 6 06-11-2004 10:28 AM
php + apache problems nocturnal Linux - Software 1 07-02-2003 08:50 PM
php on apache problems andrew001 Linux - Software 3 06-21-2003 05:14 PM

All times are GMT -5. The time now is 05:55 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration