LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-19-2003, 12:21 PM   #1
Dalius
LQ Newbie
 
Registered: Sep 2003
Location: Canadia
Distribution: Redhat 9
Posts: 4

Rep: Reputation: 0
Problems Upgrading to KDE 3.1 with qt


Distro: RH9

Hi people,

I've been trying to upgrade to KDE 3.1 for a while now, but I'm having a few problems. This what I got when first trying to install it:

Quote:
[root@localhost KDE]# rpm -Uvh *
error: Failed dependencies:
qt >= 1:3.1.2 is needed by kdeedu-3.1.4-0.9x.1
qt >= 1:3.1.2 is needed by kdelibs-3.1.4-0.9x.1
qt-devel >= 1:3.1.2 is needed by kdelibs-devel-3.1.4-0.9x.1
timidity++ is needed by kdemultimedia-3.1.4-0.9x.1
qt >= 1:3.1.2 is needed by kdenetwork-3.1.4-0.9x.1
Alright, so I went to download the newest version of the qt package, which I did.

But, when I try to install it now, I get the same error.

Can someone help me out here?
 
Old 09-19-2003, 03:15 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,750

Rep: Reputation: 271Reputation: 271Reputation: 271
Enter this command:
rpm -qi qt3
to check that the Qt version is in fact >= 3.1.2


If you installed Qt by compiling it then the rpm database did not get updated. You could be in the situation that you have Qt 3.1.2 installed but the rpm data base still thinks that you are using an earlier version. If that is the case then you can use checkinstall to create an rpm from your compiled source:

http://asic-linux.com.mx/~izto/checkinstall/index.php

and then install qt as a rpm.

Another possibility is to install KDE using the --nodeps feature of rpm. However KDE has so many dependencies besides Qt that --nodeps will probably get you into a mess.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading to KDE 3.3 problems Rv5 Linux - Software 5 11-15-2004 02:59 PM
ALSA problems after upgrading to KDE 3.2.3 mikeyt_333 Linux - Software 11 08-28-2004 07:48 PM
Upgrading to KDE 3.3 jlacroix Fedora 3 08-22-2004 02:48 PM
Upgrading to the new KDE 3.2 RobertoBech Mandriva 2 02-03-2004 05:13 PM
Upgrading KDE 2.2.2 to 3.1.4 subnet Debian 9 10-08-2003 06:59 AM


All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration