LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-14-2006, 05:02 AM   #1
alex986best
LQ Newbie
 
Registered: Jun 2006
Posts: 12

Rep: Reputation: 0
Problems upgrading MySql


I have a problem trying to upgrade mysql from version 3.23 to version 5.0

I removed the old mysql package by typing

rpm -e mysql --nodeps

Then I tyed to install the new version but I get the following error:

warning: MySQL-server-standard-5.0.22-0.rhel3.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
MySQL-server conflicts with mysql-server-3.23.58-16.RHEL3.1


What should I do?
 
Old 06-14-2006, 11:46 AM   #2
MrJoshua
Member
 
Registered: Apr 2002
Location: Houston Texas
Distribution: Debian / Gentoo / RHEL
Posts: 209

Rep: Reputation: 31
MySQL server is a separate package in RHEL. To confirm that mysql-server is still installed run the following command:

#rpm -qa | grep mysql

I am almost positive that it will return with mysql-server-3.23.58-16.RHEL3.1. You will need to uninstall this package.
rpm -e mysql-server-3.23.58-16.RHEL3.1

This should allow you to install the new version of mysql.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with MySQL on SuSE: Can't Connect (/var/lib/mysql/mysql.sock) neocookie Linux - Software 8 02-07-2008 11:48 PM
Problems upgrading to PHP5 and MySQL 5 ernesto_cgf Suse/Novell 2 04-05-2006 07:06 PM
Error compiling perl-DBD-MySQL after upgrading to MySQL 4.1 pitaro920 Linux - Software 1 01-16-2006 04:28 PM
Problems upgrading MySQL on Ubuntu, with Apache2/PHP4 peruvianllama Linux - Software 0 08-16-2005 09:27 AM
Upgrading to MySQL 4 problems Rv5 Linux - Software 1 02-19-2004 01:37 PM


All times are GMT -5. The time now is 09:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration