LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-23-2005, 11:09 PM   #1
ernesto_cgf
Member
 
Registered: Nov 2003
Location: Havana, Cuba
Distribution: Ubuntu 9.04 "Jaunty Jackalope"
Posts: 153

Rep: Reputation: 30
problems running amarok in mdk


I have mdk10.0 official, which does not comes with amarok. I downloaded and installed gstreamer 8 and amarok from an official mdk10.1 mirror. They all installed ok. amarok run ok and it detected gstreamer ok. It scanned my 14Gb+ of music into its collection. The problem is when I try to add something to the playlist from the collection, it gives me this "Some URLs could not be loaded" in the status bar for a few seconds, the playlist stays empty, and I finally get nothing played, no music, no sound at all.

What could this be? Any help please.

PS. Amarok also crashes silently when trying to change to other engines (aRts or xine).
 
Old 03-24-2005, 01:23 AM   #2
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
It might have something to do with the fact that those are 10.1 packages you installed. Mandrake tends to be rather picky about that.
 
Old 03-24-2005, 03:56 PM   #3
z-vet
Member
 
Registered: Aug 2004
Location: Israel
Distribution: Ubuntu 10.10
Posts: 271

Rep: Reputation: 34
I had a same problems, so i just compiled amaroK and all it's dependencies from source. No problems anymore.
 
Old 03-24-2005, 04:04 PM   #4
ernesto_cgf
Member
 
Registered: Nov 2003
Location: Havana, Cuba
Distribution: Ubuntu 9.04 "Jaunty Jackalope"
Posts: 153

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by z-vet
I had a same problems, so i just compiled amaroK and all it's dependencies from source. No problems anymore.
What does 'all its dependencies' mean ?? does that include gstreamer 8 ?? (I suppose so) What else is included ?? How many packages need to be compiled ??

If this is what it gets to have it right, could you lead me to where all these source packages can be obtained ??

Thanks anyway. In any case, I will be searching for this my self starting just know. Only a little push in the right direction would be nice.
 
Old 03-24-2005, 04:16 PM   #5
z-vet
Member
 
Registered: Aug 2004
Location: Israel
Distribution: Ubuntu 10.10
Posts: 271

Rep: Reputation: 34
http://amarok.kde.org/wiki/index.php/Requirements
 
Old 03-25-2005, 12:53 AM   #6
ernesto_cgf
Member
 
Registered: Nov 2003
Location: Havana, Cuba
Distribution: Ubuntu 9.04 "Jaunty Jackalope"
Posts: 153

Original Poster
Rep: Reputation: 30
I downloaded everything needed (source packages): Gstreamer, TagLib, Amarok itself, all latest versions. I already compiled TagLib succesfully (although I haven't made a make install yet).

After TagLib I tried compiling Gstreamer, but ./configure gives me this error:

Code:
configure: error: popt 1.6.3 or newer is required to build gstreamer. You can
                download the latest version from
                ftp://ftp.rpm.org/pub/rpm/dist/
I typed 'urpmi popt' and I got the message 'Everything already installed'
I typed 'rpm -qa | grep popt' and I got

Code:
popt-1.8.2-7mdk
How is that I have popt 1.8.2 and gstreamer's ./configure asks for 1.6.3 or newer? Am I missing something?
 
Old 03-25-2005, 12:58 AM   #7
ernesto_cgf
Member
 
Registered: Nov 2003
Location: Havana, Cuba
Distribution: Ubuntu 9.04 "Jaunty Jackalope"
Posts: 153

Original Poster
Rep: Reputation: 30
I think I know my mistake already. I should have installed popt-devel. I tried now ./configure just after installing it and it worked. I am now executing make
 
Old 03-25-2005, 07:30 AM   #8
ernesto_cgf
Member
 
Registered: Nov 2003
Location: Havana, Cuba
Distribution: Ubuntu 9.04 "Jaunty Jackalope"
Posts: 153

Original Poster
Rep: Reputation: 30
I compiled and installed gstreamer with no problems. Then I tried compiling gst-plugins and I got the following error during make (./configure had no errors)

Code:
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../gst-libs -I../../gst-libs -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -pthread -I/usr/local/include/gstreamer-0.8 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -DGST_DISABLE_DEPRECATED -Wall -I../../gst/tags -g -O2 -MT libgsttagedit_la-tags.lo -MD -MP -MF .deps/libgsttagedit_la-tags.Tpo -c tags.c  -fPIC -DPIC -o .libs/libgsttagedit_la-tags.o
tags.c:26:28: glib/gi18n-lib.h: No such file or directory
tags.c: In function `gst_tag_register_musicbrainz_tags':
tags.c:37: warning: implicit declaration of function `_'
tags.c:37: warning: passing arg 4 of `gst_tag_register' makes pointer from integer without a cast
tags.c:37: warning: passing arg 5 of `gst_tag_register' makes pointer from integer without a cast
tags.c:39: warning: passing arg 4 of `gst_tag_register' makes pointer from integer without a cast
tags.c:39: warning: passing arg 5 of `gst_tag_register' makes pointer from integer without a cast
tags.c:41: warning: passing arg 4 of `gst_tag_register' makes pointer from integer without a cast
tags.c:41: warning: passing arg 5 of `gst_tag_register' makes pointer from integer without a cast
tags.c:44: warning: passing arg 4 of `gst_tag_register' makes pointer from integer without a cast
tags.c:44: warning: passing arg 5 of `gst_tag_register' makes pointer from integer without a cast
tags.c:46: warning: passing arg 4 of `gst_tag_register' makes pointer from integer without a cast
tags.c:46: warning: passing arg 5 of `gst_tag_register' makes pointer from integer without a cast
tags.c:49: warning: passing arg 4 of `gst_tag_register' makes pointer from integer without a cast
tags.c:49: warning: passing arg 5 of `gst_tag_register' makes pointer from integer without a cast
make[3]: *** [libgsttagedit_la-tags.lo] Error 1
make[3]: Leaving directory `/home/ernesto/Documents/Development/amarok/gst-plugins-0.8.8/gst/tags'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ernesto/Documents/Development/amarok/gst-plugins-0.8.8/gst'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ernesto/Documents/Development/amarok/gst-plugins-0.8.8'
make: *** [all] Error 2
Does anybody knows what it means ?
 
Old 03-30-2005, 01:17 AM   #9
ernesto_cgf
Member
 
Registered: Nov 2003
Location: Havana, Cuba
Distribution: Ubuntu 9.04 "Jaunty Jackalope"
Posts: 153

Original Poster
Rep: Reputation: 30
I quit trying to compile gst-plugins, and therefore, amarok. I am turning back to juk and xmms, which are also great pieces of software.

Anyway, if someone still has some idea, please let me know.
Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems compiling amarok chrisyc Suse/Novell 10 12-21-2005 02:01 PM
amarok questions/problems awhiteknight1999 Linux - Software 7 08-19-2005 04:36 PM
Arts...Amarok...so many problems. RoaCh Of DisCor Linux - Newbie 2 05-29-2005 03:58 AM
problems with amaroK Turok Linux - Software 1 05-17-2005 09:02 AM
Problems compiling amarok ernesto_cgf Mandriva 6 12-04-2004 08:52 PM


All times are GMT -5. The time now is 05:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration