Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 01-28-2013, 01:31 PM   #1
Eduardo Mena
LQ Newbie
Registered: Sep 2011
Posts: 17

Rep: Reputation: Disabled
Problems receiving mail in qmail


I can send email to client-x, but the client-x can't send us your email.
The client-x receive an email error with the following message:

"553 sorry, your HELO host name has been denied (#5.7.1)"

My mail server is qmail (1.03 version) on Red Hat Enterprise Linux Server release 5.
The client-x have Microsoft Exchange and Sophos Email Appliance
( The Email Appliance is an appliance for filtering email.)

The /var/qmail/control/badhelo file on my server doesn't have For me, is not a badhelo.

Seven month ago I installed qmail-103.patch from
# patch -p1 < qmail-103.patch
# make setup check

I don't know if I need install another patch for qmail to resolve this problem.

I did the following test from my server :

[root@srv ~]# telnet 25
Connected to
Escape character is '^]'.
250-SIZE 22777216
250 ok
RCPT NOTIFY=success,failure
553 sorry, your HELO host name has been denied (#5.7.1)

I omitted the real domains and IP addresses for confidentiality.

I can send to everybody emails, I can receive a lot of emails, but I can't receive emails from client-x.

Someone can give me an idea of ​​what I should do.

Thanks so much.

Old 01-28-2013, 05:53 PM   #2
Senior Member
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,604

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
This is probably caused by the Sophos email appliance, I have dealt with other Sophos products and they can be very restrictive. If I remember correctly, the Sophos email filter has a built in "Whitelist" which covers 99% of valid email usage, there are some clients and some servers that dont get picked up by it and will cause a rejection.

I think this may be apart of their anti-virus suite and not actually the email appliance. Are you running the sophos anti-virus as well? can you take a quick look at the sophos logs to see if it has anything about a rejection around the time the emails are being denied?
Old 01-28-2013, 08:04 PM   #3
Eduardo Mena
LQ Newbie
Registered: Sep 2011
Posts: 17

Original Poster
Rep: Reputation: Disabled

Thank you very much for your reply. I'll offer a bit more of details to be sure that we understand each other.

In my server, there are not any Sophos products. I currently use Spamassassin, and clamAV as anti-virus.

I cannot directly verify Sophos' logs, since they are in the client's server.

Thank you


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Qmail - receiving mail too slow repolona Linux - Server 0 01-04-2008 03:04 AM
qmail not receiving mail sent from remote host ohcarol Linux - Software 20 10-07-2005 06:38 AM
Qmail Problem....? (Receiving mail) ysg08 Linux - Networking 3 01-17-2005 01:30 PM
Receiving E-Mail Problems, need help, please! bignitz Linux - Networking 11 08-09-2004 01:00 PM
problems with sendmail receiving mail isostat1 Linux - Newbie 2 01-12-2004 08:28 AM

All times are GMT -5. The time now is 09:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration