LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-24-2004, 12:12 PM   #1
xonner
LQ Newbie
 
Registered: Apr 2004
Location: Portugal
Distribution: Slackware
Posts: 19

Rep: Reputation: 0
problems installing pango-1.4.0!


When i run the configuration script i get this error message:

checking for pkg-config... /usr/local/bin/pkg-config
checking for fontconfig >= 1.0.1... Package fontconfig was not found in the pkg-config search path.
Perhaps you should add the directory containing `fontconfig.pc'
to the PKG_CONFIG_PATH environment variable
No package 'fontconfig' found
configure: WARNING: No fontconfig found, skipping tests for FreeType and Xft
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking for GLIB - version >= 2.4.0...
*** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** Glib 2.4.0 or better is required. The latest version of

I already installed glib-2.4.0 with no problems and checked the LD_LIBRARY_PATH and also the ld.so.conf file. Can anyone help me on this?
Thanks in advance.

Slackware 9.0
My "uname -a": Linux server 2.4.20 #2 Mon Mar 17 22:02:15 PST 2003 i686 unknown

Last edited by xonner; 04-24-2004 at 12:19 PM.
 
Old 04-24-2004, 02:07 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Are you installing by source or precompiled slackware packages, ex: .tgz's ?

And after installing Glib2, did you run ldconfig to update the library shares and links database? And did you remove your older version of Glib or upgraded it as it clearly is only finding it instead of the newer version?
 
Old 04-24-2004, 06:16 PM   #3
xonner
LQ Newbie
 
Registered: Apr 2004
Location: Portugal
Distribution: Slackware
Posts: 19

Original Poster
Rep: Reputation: 0
Hey trickykid, i think glib-2.2.1 was integrated when i nstalled my system i just don't know how to remove it. I did run ldconfig after installing glib-2.4.0. Can you tell me the how can i remove glib-2.2.1? Thanks
 
Old 04-24-2004, 06:50 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Well if your using slackware, the easiest way is to just do this from the /var/log/packages directory:

removepkg <package-name-to-remove>

But I would highly suggest keeping this installed as a majority of your existing packages depend on it, etc.
 
Old 05-01-2004, 02:50 PM   #5
Dartelin
LQ Newbie
 
Registered: May 2004
Posts: 19

Rep: Reputation: Disabled
I have the same problem. After i do the removepkg, I still get from pongo and gtk+ that error.
Where is LD_LIBRARY_PATH ? I run under slackware 9.1.
 
Old 05-02-2004, 05:05 PM   #6
Sn1PeR
LQ Newbie
 
Registered: Sep 2003
Posts: 26

Rep: Reputation: 15
I'm having this exact same problem, trying to get xfce4 up and running hopefully. I've done the removepkg now but am getting the same error
 
Old 05-02-2004, 05:29 PM   #7
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
OK, if you installed glib-2.4.0 from source I would make sure you installed it into /usr/lib because the default path is /usr/local/lib. Run ./configure again and this time do:
Code:
./configure --prefix=/usr
then run ldconfig and try again. I notice also that you're missing fontconfig...I had a helluva time getting that to install
 
Old 05-03-2004, 05:08 AM   #8
Dartelin
LQ Newbie
 
Registered: May 2004
Posts: 19

Rep: Reputation: Disabled
So when i do ./configure --prefix=/usr then when i do make a following error appears:
Code:
gconvert.c:47:2: #error GNU libiconv not in use but included iconv.h is from libiconv 
make[3]: *** [gconvert.lo] Error 1 
make[3]: Leaving directory `/home/Dartelin/Downloads/temp/glib-2.4.1/glib' 
make[2]: *** [all-recursive] Error 1 
make[2]: Leaving directory `/home/Dartelin/Downloads/temp/glib-2.4.1/glib' 
make[1]: *** [all-recursive] Error 1 
make[1]: Leaving directory `/home/Dartelin/Downloads/temp/glib-2.4.1' 
make: *** [all] Error 2
Should i install fonconfig ?
 
Old 05-03-2004, 04:27 PM   #9
Sn1PeR
LQ Newbie
 
Registered: Sep 2003
Posts: 26

Rep: Reputation: 15
How do you reinstall glibc_2.3.2 ... it's needed for X lol
 
Old 05-03-2004, 04:33 PM   #10
Sn1PeR
LQ Newbie
 
Registered: Sep 2003
Posts: 26

Rep: Reputation: 15
checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0... Requested 'pango >= 1.4.0' but version of Pango is 1.2.1

configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

this is after pango 1.4 installed fine so now I have anew problem... should I remove some old version somewhere?
 
Old 05-04-2004, 05:54 AM   #11
Dartelin
LQ Newbie
 
Registered: May 2004
Posts: 19

Rep: Reputation: Disabled
Quote:
Originally posted by Sn1PeR
How do you reinstall glibc_2.3.2 ... it's needed for X lol
Man we reinstall glib-2.4.0 not glibc-2.3.2
 
Old 05-04-2004, 10:36 AM   #12
Sn1PeR
LQ Newbie
 
Registered: Sep 2003
Posts: 26

Rep: Reputation: 15
I figured it out. Put the cd in and installpkg *.tgz in the /mnt/cdrom/slackware/x dir.. it's installed w/ x
 
Old 05-17-2004, 09:10 AM   #13
wmeler
Member
 
Registered: Dec 2003
Distribution: Linux Mint 15 (Cinnamon)
Posts: 215

Rep: Reputation: 18
http://www.linuxquestions.org/questi...ight=pango+1.4


AND THE FOLLOWING THREAD (FOLLOW IT THROUGH TO THE END)...

http://mail.gnome.org/archives/gtk-l.../msg00152.html
 
Old 05-17-2004, 09:43 AM   #14
wmeler
Member
 
Registered: Dec 2003
Distribution: Linux Mint 15 (Cinnamon)
Posts: 215

Rep: Reputation: 18
http://www.linuxquestions.org/questi...hreadid=171815
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error in the creation of `etc/pango/pango.modules` okeyla Linux - Newbie 3 07-02-2011 08:06 PM
Pango not found while installing gtk+-2.8.7 lj4 Linux - Software 7 06-04-2008 12:39 AM
Installing gtk,glib, pango af_dave Linux - Software 5 07-28-2004 03:48 AM
error installing pango shams Linux - Software 5 04-22-2004 09:22 PM
Installing pango, wireless networking stryfe Linux - Newbie 3 11-06-2003 05:30 PM


All times are GMT -5. The time now is 12:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration