LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   problems installing image viewer (Kradview) due to DocBook issues (http://www.linuxquestions.org/questions/linux-software-2/problems-installing-image-viewer-kradview-due-to-docbook-issues-908486/)

djmb 10-16-2011 05:19 PM

problems installing image viewer (Kradview) due to DocBook issues
 
Hi all,

i am trying to install a soft for medical image viewing (Kradview). I got into a few issues when running ./configure. One of them was that the prg is for KDE and i am running XFCE, but eventually, i managed to solve all issues.

However, the make command output shows there is another error:

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
squeeze@debian:~/downloads/kradview-1.1.0$ make
make all-recursive
make[1]: Entering directory `/home/squeeze/downloads/kradview-1.1.0'
Making all in doc
make[2]: Entering directory `/home/squeeze/downloads/kradview-1.1.0/doc'
Making all in .
make[3]: Entering directory `/home/squeeze/downloads/kradview-1.1.0/doc'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/home/squeeze/downloads/kradview-1.1.0/doc'
Making all in en
make[3]: Entering directory `/home/squeeze/downloads/kradview-1.1.0/doc/en'
/usr/bin/meinproc --check --cache index.cache.bz2 ./index.docbook
/usr/share/apps/ksgmltools2/docbook/xml-dtd-4.1.2/dbhierx.mod:173: warning: failed to load external entity "/usr/share/apps/ksgmltools2/customization/dtd/rdbhier2.elements"
%rdbhier2;
^
Entity: line 1:
%rdbhier2;
^
/usr/share/apps/ksgmltools2/customization/obsolete/modifications.elements:13: validity error : Redefinition of element book
| colophon)*)>
^
/usr/share/apps/ksgmltools2/customization/obsolete/modifications.elements:34: validity error : Redefinition of element bookinfo
| %bibliocomponent.mix; | keywordset)*)>
^
make[3]: *** [index.cache.bz2] Error 1
make[3]: Leaving directory `/home/squeeze/downloads/kradview-1.1.0/doc/en'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/squeeze/downloads/kradview-1.1.0/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/squeeze/downloads/kradview-1.1.0'
make: *** [all] Error 2
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

So i tried to look into it but here I am stuck. Looks like there are issues with DocBook, but I am not sure.

Any idea? Any help would be greatly appreciated.

Cheers,

John VV 10-16-2011 06:54 PM

not sure but it looks like old code using a NEW gcc
how old is this program and what version of gcc

the newer gcc 4.6,4.5,4.3 are more strict than gcc 4.0 and 4.1
and the 4 series is WAY more strict that the old gcc 3 series

some googling
you are using this ?
http://www.orcero.org/irbis/kradview/

i am looking at the dates on the code
2008 and 2005

it will NOT build without errors on gcc 4.5
4.3 ? might
the freshmeet 2008 update is to build on gcc 4.3 )
http://freshmeat.net/projects/kradview/
gcc 4.1 it should ???
and gcc 3.4 it will

---------- edit -----------
on opensuse 11.4
configure errors
it needs the VERY OLD Qt3.0 or QT2 ( QT needs to be less that 3.0) source ( 3.5 is the current legacy )
i will not be of any help
i do not intend on installing qt2 or 3.0

djmb 10-23-2011 01:49 PM

OK,

thanks for the tip. Sorry for my late answer, I was away.

Yes I am trying to install Kradview. I'll try to see if I can install with gcc 3.4. Although, I don't want to compromise my current distribution (Debian Squeeze); and i not sure how this will affect it. I wanted to contact the guy who developed the software but I cannot find an email address. Anyway, as usual, it's gonna need a fair bit of work!

Thx,

John VV 10-23-2011 02:51 PM

Quote:

I wanted to contact the guy who developed the software but I cannot find an email address. Anyway, as usual, it's gonna need a fair bit of work!
http://www.orcero.org/irbis/kradview/

seeing as the 2008 release was a bug fix for gcc 4.3
and it is mostly unsupported and most of the code was rote in 05 ( 6 years ago )

is there an overwhelming NEED to use this EXACT program

there are many programs that can read the 16 bit x-ray images

you are going to need qt 2 installed and qt4 is the norm.


All times are GMT -5. The time now is 05:23 PM.