LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-18-2012, 07:20 AM   #1
Raheel Hassan
LQ Newbie
 
Registered: Mar 2009
Posts: 24

Rep: Reputation: 0
Problems in installing Skype on Ubuntu 12.10.


I want to install skype on my newly installed machine 64bit architecture. When i tried to install using software center it gives in an error that lib32sdtc++6 in not installed. When i tried to install lib32sdtc++6 it gives me under given error,
The following packages have unmet dependencies:
lib32stdc++6 : Depends: lib32gcc1 (>= 1:4.1.1) but it is not going to be installed
Depends: libc6-i386 (>= 2.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When i tried to install libc6-i386 it gives me under given error,
The following packages have unmet dependencies:
libc6-i386 : Depends: libc6 (= 2.15-0ubuntu18) but 2.15-0ubuntu20 is to be installed
E: Unable to correct problems, you have held broken packages.


and this problem continues every time I try to install the dependenceses.

Could any one give me the clue how to fix this problem.

I am also facing the similar problems while installing virtual box but in that case the packages are mostly related qt4.


Regards,
 
Old 11-18-2012, 08:06 PM   #2
lamegaptop
Member
 
Registered: Sep 2009
Location: Orlando
Distribution: Debian
Posts: 49

Rep: Reputation: 4
Have you looked here?

https://help.ubuntu.com/community/Skype

The help page doesn't mention multiarch but this package pulls in most all the 32 bit libraries in one fell swoop:

http://packages.ubuntu.com/quantal/ia32-libs-multiarch

I would suggest using command line or synaptic to install stuff but that is just my opinion. Never cared for software center....
 
Old 11-19-2012, 03:09 AM   #3
Raheel Hassan
LQ Newbie
 
Registered: Mar 2009
Posts: 24

Original Poster
Rep: Reputation: 0
After executing the commands mentioned in the link,
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

I got these errors.
.....................................
.....................................
Ign http://pk.archive.ubuntu.com quantal-backports/restricted Translation-en_US
Ign http://pk.archive.ubuntu.com quantal-backports/universe Translation-en_US
Fetched 29.2 kB in 3min 8s (154 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
default-jre-headless : Depends: openjdk-7-jre-headless (>= 7~u3-2.1) but it is not going to be installed
openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u9-2.3.3-0ubuntu1~12.10.1) but it is not going to be installed
Depends: libasound2 (>= 1.0.16)
Depends: libcups2 (>= 1.4.0) but it is not going to be installed
Depends: libfontconfig1 (>= 2.9.0) but it is not going to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
Depends: libgtk2.0-0 (>= 2.8.0) but it is not going to be installed
Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
Depends: libpulse0 (>= 1:0.99.1) but it is not going to be installed
Depends: libx11-6 but it is not going to be installed
Depends: libxext6 but it is not going to be installed
Depends: libxi6 but it is not going to be installed
Depends: libxrender1 but it is not going to be installed
Depends: libxtst6 but it is not going to be installed
Depends: libxrandr2 but it is not going to be installed
Depends: libxinerama1 but it is not going to be installed
Depends: libgl1-mesa-glx but it is not going to be installed
Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed
Recommends: libgnome2-0 but it is not going to be installed
Recommends: libgnomevfs2-0 but it is not going to be installed
Recommends: libgconf2-4 but it is not going to be installed
skype : Depends: skype-bin
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
noise in skype to skype calls in skype v2.1 beta for fedora mq15 Linux - Software 0 01-20-2010 12:04 AM
problems installing ubuntu live cd hard drive problems! icturubyz2 Linux - Newbie 2 05-26-2009 12:07 AM
Problems installing the Ubuntu Netbook Remix package over Ubuntu 8.10 unluckystuntman Linux - Newbie 3 12-30-2008 12:19 AM
quest for Qt 3.2 (aka, problems installing skype) mindstormsguy Linux - Software 3 06-26-2004 07:25 AM


All times are GMT -5. The time now is 02:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration