LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problems in installing Skype on Ubuntu 12.10. (http://www.linuxquestions.org/questions/linux-software-2/problems-in-installing-skype-on-ubuntu-12-10-a-4175437671/)

Raheel Hassan 11-18-2012 07:20 AM

Problems in installing Skype on Ubuntu 12.10.
 
I want to install skype on my newly installed machine 64bit architecture. When i tried to install using software center it gives in an error that lib32sdtc++6 in not installed. When i tried to install lib32sdtc++6 it gives me under given error,
The following packages have unmet dependencies:
lib32stdc++6 : Depends: lib32gcc1 (>= 1:4.1.1) but it is not going to be installed
Depends: libc6-i386 (>= 2.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When i tried to install libc6-i386 it gives me under given error,
The following packages have unmet dependencies:
libc6-i386 : Depends: libc6 (= 2.15-0ubuntu18) but 2.15-0ubuntu20 is to be installed
E: Unable to correct problems, you have held broken packages.


and this problem continues every time I try to install the dependenceses.

Could any one give me the clue how to fix this problem.

I am also facing the similar problems while installing virtual box but in that case the packages are mostly related qt4.


Regards,

lamegaptop 11-18-2012 08:06 PM

Have you looked here?

https://help.ubuntu.com/community/Skype

The help page doesn't mention multiarch but this package pulls in most all the 32 bit libraries in one fell swoop:

http://packages.ubuntu.com/quantal/ia32-libs-multiarch

I would suggest using command line or synaptic to install stuff but that is just my opinion. Never cared for software center....

Raheel Hassan 11-19-2012 03:09 AM

After executing the commands mentioned in the link,
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

I got these errors.
.....................................
.....................................
Ign http://pk.archive.ubuntu.com quantal-backports/restricted Translation-en_US
Ign http://pk.archive.ubuntu.com quantal-backports/universe Translation-en_US
Fetched 29.2 kB in 3min 8s (154 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
default-jre-headless : Depends: openjdk-7-jre-headless (>= 7~u3-2.1) but it is not going to be installed
openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u9-2.3.3-0ubuntu1~12.10.1) but it is not going to be installed
Depends: libasound2 (>= 1.0.16)
Depends: libcups2 (>= 1.4.0) but it is not going to be installed
Depends: libfontconfig1 (>= 2.9.0) but it is not going to be installed
Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
Depends: libgtk2.0-0 (>= 2.8.0) but it is not going to be installed
Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
Depends: libpulse0 (>= 1:0.99.1) but it is not going to be installed
Depends: libx11-6 but it is not going to be installed
Depends: libxext6 but it is not going to be installed
Depends: libxi6 but it is not going to be installed
Depends: libxrender1 but it is not going to be installed
Depends: libxtst6 but it is not going to be installed
Depends: libxrandr2 but it is not going to be installed
Depends: libxinerama1 but it is not going to be installed
Depends: libgl1-mesa-glx but it is not going to be installed
Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed
Recommends: libgnome2-0 but it is not going to be installed
Recommends: libgnomevfs2-0 but it is not going to be installed
Recommends: libgconf2-4 but it is not going to be installed
skype : Depends: skype-bin
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


All times are GMT -5. The time now is 04:33 AM.