Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-17-2005, 05:24 PM   #1
Registered: Jan 2005
Location: Alamogordo
Distribution: Gentoo 2005.0
Posts: 136

Rep: Reputation: 15
Question problems compiling kernel ---- [drivers/md/dm-snapshot.ko] undefined

i recompiling my kernel to get alsa for sound support. i did "make menuconfig" and went through everything. i exited, saved, and typed make. along the way it said

WARNING: /lib/modules/2.6.11-gentoo-r3/kernel/drivers/md/dm-snapshot.ko needs unknown symbol dm_table_get_size
*** Warning: "dm_table_get_size" [drivers/md/dm-snapshot.ko] undefined!
then i did "make modules_install". it ran through and in about 15-20 seconds it said
if [ -r ]; then /sbin/depmod -ae -F  2.6.11-gentoo-r3; fi
WARNING: /lib/modules/2.6.11-gentoo-r3/kernel/drivers/md/dm-snapshot.ko needs unknown symbol dm_table_get_size
what do i do to fix this?

also. is there anything i need to do, since im recompiling anyway, to get my synaptics touchpad to work. right now i have basic support but i cant tap to drag or scroll. its kind of annoying. or can i just wait and do it later by installing a driver for it somewhere?

Last edited by nenyo; 07-17-2005 at 07:18 PM.
Old 07-17-2005, 07:54 PM   #2
LQ Newbie
Registered: Mar 2005
Location: europe
Distribution: Gentoo ,MDK
Posts: 7

Rep: Reputation: 0
That 'md' sounds like it have something to do with raid, have you configured raid on that machine (or in menuconfig) ?
Old 07-17-2005, 08:14 PM   #3
Registered: Jan 2005
Location: Alamogordo
Distribution: Gentoo 2005.0
Posts: 136

Original Poster
Rep: Reputation: 15
i dont know what raid is... (i feel dumb)
how would i go about doing so???

i do have raid checked as a module in the menuconfig. but what does this have to do with my problem?

i was getting an error when i loaded gnome. it sayed something to the effect of (no volume control devices found). so i looked around and people said to recompile the kernel with alsa (which i didn't and may still not have). so thats what im trying to do. while waiting for an answer on this forum i decided to install xmms to see what happens.

i can play music in xmms and i dont get the error when i load gnome anymore(???). the default volume is set to zero though (kind of anoying). the error stopped before i installed xmms though. and when i try to play anything in totem it says device busy or not available. i didn't do anything realy... im confused.

Last edited by nenyo; 07-18-2005 at 02:14 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia drivers on kernel 2.6.x problems ome bos Linux - Hardware 1 07-12-2005 10:11 AM
Problems isntalling NVIDIA Drivers with kernel 2.6.11 sys7em Linux - Hardware 1 03-07-2005 12:03 PM
Problems getting kernel sources for 10.2 cooker snapshot Passive Mandriva 0 01-02-2005 04:05 PM
comiling Orinoco drivers to run in Mointor mode BlackIP Linux - Wireless Networking 0 07-13-2004 09:08 PM
RH 7.3, Kernel, upgrade problems and updating drivers!!!!!!!!!!!! admedic Linux - Newbie 5 08-18-2002 08:25 PM

All times are GMT -5. The time now is 09:47 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration