LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-03-2003, 04:30 AM   #1
DustOffTryAgain
Member
 
Registered: Jul 2003
Location: Somewhere
Distribution: Suse 8.2
Posts: 30

Rep: Reputation: 15
Problems changing permissions of mount point


Hello.

Running mandrake 9.1 on this particular box.

I created a fat32 partition which mounts at /mnt/win_d
I want to be able to drop files into this directory from my user accounts. I executed chmod 777 /mnt/win_d as root. ls-l reveals that /mnt/win still has permissions of: drwxr--r--

What gives? Am I not allowed to chmod mount points? How do I open up this shared partition to my user accounts so I can place files on this partition to share with windows?

Thanks.
 
Old 09-03-2003, 05:40 AM   #2
yuray
Member
 
Registered: Apr 2003
Location: Russia, Khotkovo
Distribution: Debian
Posts: 146

Rep: Reputation: 15
In fstab add option
user
and mount from user.
 
Old 09-03-2003, 10:28 AM   #3
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
The permissions of the directory get overridden in favour of the filesystem permissions when one gets mounted at that mount point. If you want write permissions you'll have to specify them in /etc/fstab. I'm not sure whether "user" will solve your problems (but try it), you may need to specify gid=<user group number> and/or uid=<your user name/number>.
 
Old 09-03-2003, 12:16 PM   #4
DustOffTryAgain
Member
 
Registered: Jul 2003
Location: Somewhere
Distribution: Suse 8.2
Posts: 30

Original Poster
Rep: Reputation: 15
Thank you both for your replies.

I ended up configuring the partition with mandrake, as I found an advanced setting burried in the menus which allows that partition to be accessed by all users.

On an unrelated note, would either of you know where the linux equivalent of M$'s "startup folder" is?
 
Old 09-03-2003, 12:23 PM   #5
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
if you're using kde it is
~/.kde/Autostart
you can place things there to be started automatically. It's best done with a script placed there (make sure you make it executable).Placing links (something like shortcuts) could work too. I'm not sure. just try.

Another place is
~/.bashrc
But this might not be the right place for your purposes.
 
Old 09-03-2003, 12:37 PM   #6
DustOffTryAgain
Member
 
Registered: Jul 2003
Location: Somewhere
Distribution: Suse 8.2
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks quatsch!

Back to the old issue. Here's my /etc/fstab:

/dev/hda5 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c ntfs iocharset=iso8859-1,ro 0 0
/dev/hda7 /mnt/win_d vfat user,iocharset=iso8859-1,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0

User is already in there, but I can't create new directories in /mnt/win_d. Where do I, <insert gid=#> or <uid=#>?
 
Old 09-03-2003, 12:41 PM   #7
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You insert it in the options, along with stuff such as iocharset=iso8859-1.
 
Old 09-03-2003, 01:50 PM   #8
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Quote:
On an unrelated note, would either of you know where the linux equivalent of M$'s "startup folder" is?
For each run level in Mandrake there is a corresponding directory which contains S symlinks which point to the actuall services in /etc/rc.d/init.d - these symlink directories are /etc/rc.d/rcx.d were x is simply the respective run level - you can start or stop certain services on boot up by taking out or putting in these symlinks to the actual services - I wouldnt advise jumping straight into this but read up on it first so youve got a better grasp, both of what youre doing and what services your modifying.


Quote:
/dev/hda7 /mnt/win_d vfat user,iocharset=iso8859-1,codepage=850 0 0
The options field is the 4th field in /etc/fstab - you might want to try

umask=000

as an option aswell as your uid and gid
 
Old 09-03-2003, 04:47 PM   #9
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
It seems that your fstab file is not formatted very well. You could format it using the tab key and field headings. The headings are:
#<file system> <mountpoint> <type> <options> <dump> <pass>

Note the "#" at the start of the line. It's not a heading but will have to be there to comment out the line otherwise it linux will try to parse it.
 
Old 09-03-2003, 07:28 PM   #10
DustOffTryAgain
Member
 
Registered: Jul 2003
Location: Somewhere
Distribution: Suse 8.2
Posts: 30

Original Poster
Rep: Reputation: 15
My /etc/fstab now looks like this:

#/dev/hda5 / ext2 defaults 1 1
#none /dev/pts devpts mode=0620 0 0
#none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850 0 0
#none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850 0 0
#/dev/hda1 /mnt/win_c ntfs iocharset=iso8859-1,ro 0 0
#/dev/hda7 /mnt/win_d vfat user,iocharset=iso8859-1,umask=000,gid=501,uid=501,codepage=850 0 0
#none /proc proc defaults 0 0
#/dev/hda6 swap swap defaults 0 0

Still don't have write permissions to that directory. Am I doing something idiotic?
 
Old 09-03-2003, 07:37 PM   #11
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Did you just put hashes in front of all your lines?
 
Old 09-03-2003, 08:59 PM   #12
DustOffTryAgain
Member
 
Registered: Jul 2003
Location: Somewhere
Distribution: Suse 8.2
Posts: 30

Original Poster
Rep: Reputation: 15
Yeah, that's how I interpretted adz's message... I added "umask=000,gid=501,uid=501" too.

I'm that far off, eh?
 
Old 09-04-2003, 12:42 AM   #13
DustOffTryAgain
Member
 
Registered: Jul 2003
Location: Somewhere
Distribution: Suse 8.2
Posts: 30

Original Poster
Rep: Reputation: 15
I feel pretty stupid now. I figured out what I was doing, and what adz was getting it.

For the record, here is the /etc/fstab configuration that works:

#/dev/hda5 / ext2 defaults 1 1
#none /dev/pts devpts mode=0620 0 0
#none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850 0 0
#none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850 0 0
#/dev/hda1 /mnt/win_c ntfs iocharset=iso8859-1,ro 0 0
#/dev/hda7 /mnt/win_d vfat iocharset=iso8859-1,umask=000,gid=501,uid=501,codepage=850 0 0
#none /proc proc defaults 0 0
#/dev/hda6 swap swap defaults 0 0

Last edited by DustOffTryAgain; 09-04-2003 at 12:44 AM.
 
Old 09-04-2003, 09:04 PM   #14
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Hmmm... You still have hashes in all you lines. I only meant for you to put them in the title line (the one with <file system> <mount point> etc). This then gives you a clear bunch of fields to work with. Mine looks like this:

# <file system> <mount point> <type> <options> <dump><pass>
/dev/hda2 / ext3 errors=remount-ro 0 1
/dev/hdb1 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/hdb2 /freebsd ufs ro,ufstype=44bsd 0 0
/dev/hdc /floppy vfat user,noauto 0 0
/dev/cdrom /cdrom iso9660 ro,user,noauto 0 0

Putting a hash in the line comments out the line. Sorry I wasn't clear enough on that. I can't believe that file worked. You've commented out everything.

Edit: Grrr.... I can't get this properly formatted on this site. You'll have to use your imagination. I looks great on the edit page but crappy on the post. All I was saying was that if you format it nicely, you'll find it easier to read.

Last edited by adz; 09-04-2003 at 09:08 PM.
 
Old 09-04-2003, 10:18 PM   #15
DustOffTryAgain
Member
 
Registered: Jul 2003
Location: Somewhere
Distribution: Suse 8.2
Posts: 30

Original Poster
Rep: Reputation: 15
Okay, I interpretted your comment originally to mean that I should put the hashes on each line of /etc/fstab. After I got it working without them, I thought you meant to put them in the example of the file that I post, to compensate for the forum software's wordwrap. I don't have any hashes in my real file, I just put them in the version that I posted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with smbfs mount-point in /etc/fstab - "mount -a" works, but not at boottime MarkSide Linux - Software 4 11-20-2005 04:30 PM
samba mount point problems novacrasher Linux - Wireless Networking 1 12-02-2004 10:58 PM
smbmount is messing with mount point permissions Sohni Linux - Networking 1 04-06-2004 11:37 AM
Heavy problems with mount and permissions in Debian bureado Linux - General 1 12-08-2003 12:04 AM
newbie mount point problems bootlegr Linux - Newbie 5 05-03-2002 02:22 PM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration