LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-26-2004, 03:59 AM   #1
weiss
LQ Newbie
 
Registered: Jul 2003
Location: St.Petersburg
Distribution: Mandrake 10.1
Posts: 18

Rep: Reputation: 0
Problems: building mozilla with SVG on Mandrake 9.2


Hello,
I am trying to build Mozilla with SVG support on Mandrake 9.2 (NOT via CVS - I download the archived source and then build from it). I get no errors during the building process (at least I think so), but when I am pointing the browser to any .svg file nothing happens (and there's no 'Save as...' dialog either) and the file just will not open.

I have downloaded a pre-built package with SVG support http://ftp.mozilla.org/pub/mozilla.o...gnu-svg.tar.gz and it worked - I could open .svg files fine.

The about:buildconfig on this pre-built package gives the following:

========================================================
Build platform
target
i686-pc-linux-gnu

Build tools
Compiler Version Compiler flags
gcc gcc version 2.96 20000731 (Red Hat Linux 7.2 2.96-112.7.1) -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pthread -pipe
c++ gcc version 2.96 20000731 (Red Hat Linux 7.2 2.96-112.7.1) -frtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-long-long -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--enable-optimize=-O --disable-debug --enable-cpp-rtti --enable-xterm-updates --enable-mathml --enable-crypto --enable-svg --enable-svg-renderer-libart --enable-mng --enable-xsl --enable-ldap --enable-nspr-autoconf --enable-extensions=all --with-xprint --without-system-nspr --without-system-zlib --without-system-jpeg --without-system-png --without-system-mng --disable-tests --disable-pedantic
========================================================

So, I set all the same configure arguments (just for the heck of it!) for my build and tried to build anew, but it did not work again.
Here is about:buildconfig on MY build:

========================================================
Build platform
target
i686-pc-linux-gnu

Build tools
Compiler Version Compiler flags
gcc gcc version 3.3.1 (Mandrake Linux 9.2 3.3.1-2mdk) -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pthread -pipe
c++ gcc version 3.3.1 (Mandrake Linux 9.2 3.3.1-2mdk) -frtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-long-long -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--enable-optimize=-O --disable-debug --enable-cpp-rtti --enable-xterm-updates --enable-mathml --enable-crypto --enable-svg --enable-svg-renderer-libart --enable-mng --enable-xsl --enable-ldap --enable-nspr-autoconf --enable-extensions=all --with-xprint --without-system-nspr --without-system-zlib --without-system-jpeg --without-system-png --without-system-mng --disable-tests --disable-pedantic
========================================================

As you can see all options are the same, so I have no idea what is wrong. Please, help me if you have any idea what is wrong.

Thanks a lot!
 
Old 01-26-2004, 08:27 AM   #2
hellblade
Member
 
Registered: Jan 2004
Location: Greece
Distribution: Debian Sid
Posts: 58

Rep: Reputation: 15
I can't help you exactly with your programming problem but why don't you just keep the precompiled mozilla you downloaded?
If I'm not wrong there might be an extension out there providing SVG support.
 
Old 01-26-2004, 10:17 AM   #3
weiss
LQ Newbie
 
Registered: Jul 2003
Location: St.Petersburg
Distribution: Mandrake 10.1
Posts: 18

Original Poster
Rep: Reputation: 0
Hmm,
It is not programming program I think, but maybe I have some libraries missing, but it does not say anything during the build process...

I would like to build mozilla optimised for my PC and with the functions I need, so that pre-built one does not work for me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Having problems Building OpenGL App on Mandrake 10.1 Official CelticBlues Mandriva 2 11-18-2005 12:06 PM
Building Mozilla or FireFox from source complete Programming 4 09-15-2005 11:52 PM
what is svg really? ZaphyR Linux - General 2 01-10-2005 03:09 PM
I need help with a command value for building the MPlayer Plug-in for Mozilla... Ausar Linux - Newbie 2 08-01-2004 10:44 AM
Problem building Mozilla 1.7 with GCC 3.4.1 DocMarco Linux - Software 1 07-06-2004 11:53 AM


All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration