LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-04-2004, 11:18 PM   #1
phoenix
LQ Newbie
 
Registered: Jan 2003
Location: PA
Distribution: Gentoo
Posts: 27

Rep: Reputation: 15
problems alsa 1.0.3 kernel 2.6.4 no sound


I am having a problem with alsa and not getting any sound. I managed to get it working, however, when I reboot I no longer have sound. I use Gentoo and I added alsasound to boot and seem to have all the proper modules and menuconfig selections. To see my files and afew more specifics...
http://forums.gentoo.org/viewtopic.p...725&highlight=

Any help would be appreciated...
 
Old 04-05-2004, 12:23 AM   #2
Sargek
Member
 
Registered: Jan 2003
Location: San Antonio, Texas
Distribution: Debian testing
Posts: 416

Rep: Reputation: 32
Re: problems alsa 1.0.3 kernel 2.6.4 no sound

Quote:
Originally posted by phoenix
I am having a problem with alsa and not getting any sound. I managed to get it working, however, when I reboot I no longer have sound. I use Gentoo and I added alsasound to boot and seem to have all the proper modules and menuconfig selections. To see my files and afew more specifics...
http://forums.gentoo.org/viewtopic.p...725&highlight=

Any help would be appreciated...
I am guessing you got it working by running alsaconf or alsamixer, correct? If that is the case, after whatever you did to enable sound, you need to run, as root, 'alsactl store' without the quotes. That will save your settings.

Update - just read your Gentoo post: what I suggested, you already tried. Sorry...

Paul

Last edited by Sargek; 04-05-2004 at 12:26 AM.
 
Old 04-05-2004, 12:31 AM   #3
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Well an alsactl store is all well and good but it's useless without an alsactl restore when you boot.
 
Old 04-05-2004, 12:41 AM   #4
phoenix
LQ Newbie
 
Registered: Jan 2003
Location: PA
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by adz
Well an alsactl store is all well and good but it's useless without an alsactl restore when you boot.
thnx for the suggestion...i tried it with no results.

any other thoughts?

using kde3.2.1 alsa1.0.3 kernel2.6.4
the only indication that i get that it doesn't work is that no sound comes out of the speakers unless I recompile all the alsa stuff. even aRts Control Tool shows sound playing.

I dont wanna have to recomplie alsa everytime I reboot just to have sound...
 
Old 04-05-2004, 06:45 AM   #5
Sargek
Member
 
Registered: Jan 2003
Location: San Antonio, Texas
Distribution: Debian testing
Posts: 416

Rep: Reputation: 32
Alsa

Quote:
Originally posted by adz
Well an alsactl store is all well and good but it's useless without an alsactl restore when you boot.
No kidding....normally alsactl restore is called by an init script on boot - /etc/rc.d/rc.alsa, in my case.
 
Old 04-05-2004, 07:25 AM   #6
meldar
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Gentoo
Posts: 136

Rep: Reputation: 15
I have experienced the same problem, sound suddenly worked but after a reboot it didn't. I got it working by downloading and running a utililty called alsaconf. See this thread: http://www.linuxquestions.org/questi...hreadid=153849

Which sound-related /dev-files do you have (/dev/dsp)?
Also try to manually load the sound-modules and restore the volume.

/meldar
 
Old 04-05-2004, 08:58 AM   #7
phoenix
LQ Newbie
 
Registered: Jan 2003
Location: PA
Distribution: Gentoo
Posts: 27

Original Poster
Rep: Reputation: 15
well I tried alsaconf and this is what I get:
Code:
bash-2.05b# alsaconf
/usr/sbin/alsaconf: line 33: [: too many arguments
/usr/sbin/alsaconf: line 35: [: too many arguments
which: no dialog in (/usr/kde/3.2/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3:/opt/ati/bin:/usr/X11R6/bin:/opt/blackdown-jdk-1.4.1/bin:/opt/blackdown-jdk-1.4.1/jre/bin:/usr/qt/3/bin:/usr/kde/3.2/sbin:/usr/kde/3.2/bin)
which: no whiptail in (/usr/kde/3.2/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3:/opt/ati/bin:/usr/X11R6/bin:/opt/blackdown-jdk-1.4.1/bin:/opt/blackdown-jdk-1.4.1/jre/bin:/usr/qt/3/bin:/usr/kde/3.2/sbin:/usr/kde/3.2/bin)
Error, dialog or whiptail not found.
bash-2.05b#
this doesn't mean a whole lot to me but maybe someone else will understand it...
 
Old 04-05-2004, 09:34 AM   #8
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Looks like it's looking for the dialog and whiptail binaries.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA sound problems, 2.6.7 kernel, sis7012 onboard phunkymunky Slackware 7 08-26-2004 05:10 PM
no sound with kernel 2.6.2 and alsa sirphoenix Linux - Newbie 15 02-17-2004 01:54 PM
Problems with OSS while trying to avoid problems in ALSA (scratchy sound) GT_Onizuka Linux - General 1 02-05-2004 11:55 PM
Nforce sound problems with ALSA and 2.6 Kernel! britishnemesis Linux - Hardware 4 11-29-2003 08:47 PM
Can I load both oss (kernel sound drivers) and alsa in 2 sound cared system? cmisip Linux - General 0 04-12-2003 01:27 AM


All times are GMT -5. The time now is 11:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration