LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-04-2003, 12:23 AM   #1
chamanrana
LQ Newbie
 
Registered: Aug 2003
Location: India
Distribution: Red Hat
Posts: 12

Rep: Reputation: 0
Angry Problem with Time Zone Configuration


HI,
I installed Red Hat Linux 9 on IBM Intellistation M Pro. There seems to be slight problem with time. During boot time it shows the bios time but when the system logs on to X mode it offsets the time from UTC to IST(Indian Standard Time). So if Bios time is 5:00 PM and on X windows it shows 10:30 pm IST. I have not set the time to UTC. If I set to UTC then I have problem in Windows since it is dual booting PC. I tried running setup command. I get the screen where time zone configuration option is there but if I select it nothing happens. I won't be able to open the time zone configuration screen. The program seems to be corrupted. I tried to go through many websites and books but no solutions. Since I am novice user pls let me know how can I reinstall or correct that setup package. It is urgent.
Thanks,
Chaman
 
Old 08-04-2003, 02:03 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 49
what does /etc/sysconfig/clock say

Have you tried reinstalling the redhat-config-date rpm?
 
Old 08-04-2003, 06:00 AM   #3
chamanrana
LQ Newbie
 
Registered: Aug 2003
Location: India
Distribution: Red Hat
Posts: 12

Original Poster
Rep: Reputation: 0
Hi,
The content of /etc/sysconfig/clock is

ZONE="Asia/Calcutta"
UTC=false
ARC=false

and redhat-config-date is working fine. Time zone configuration from setup command is not working pls kindly help me out
 
Old 08-04-2003, 04:26 PM   #4
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
1) When you computer first boots up, go into the BIOS and make sure
that the system clock is showing the correct local time.

2) After booting up run as user root

/usr/sbin/redhat-config-time

3) Click to the second tab, labeled "Time Zone", on the window which appears.

4) Ensure that the box at the bottom of the window next to the text

"System Clock Uses UTC"

does not have a cross or check mark in it, by clicking on it, if it does.
 
Old 08-04-2003, 10:48 PM   #5
chamanrana
LQ Newbie
 
Registered: Aug 2003
Location: India
Distribution: Red Hat
Posts: 12

Original Poster
Rep: Reputation: 0
HI Corin,
Thanks for ur reply. I tried what u have told me to but since my system is dual boot b/w Win2k and Linux my windows date is getting affected and I don't want the date to come on GMT. I want it to come on IST(Indian Standard Time). If I type setup from the terminal I am not able to open Time zone configuration window. Can u pls tell me how can I correct that particular package.
Regards,
Chaman
 
Old 08-04-2003, 11:33 PM   #6
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
You failed to comprehend what I wrote above.

In order to keep your XP happy, and you happy, we want the time in the BIOS to be IST not UTC (or GMT).

In order to run the configuration program for time, you run as root at the command line prompt the command

# redhat-config-time

not

# setup

And once you run this program, we make sure that the program is told
that the BIOS is not set to UTC.

If you cannot run the program redhat-config-time, then you need to install the package

redhat-config-date

from your RedHat cdroms.
 
Old 08-05-2003, 12:54 AM   #7
chamanrana
LQ Newbie
 
Registered: Aug 2003
Location: India
Distribution: Red Hat
Posts: 12

Original Poster
Rep: Reputation: 0
hi,
I want to know if we r not running x windows in which we install redhat-config-time then i think setup command leads to time zone configuration which is corrupt can u tell me how can I again install that or troubleshoot it.
Thanks,
Chaman
 
Old 08-05-2003, 03:27 PM   #8
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
$ rpm -qf /usr/bin/setup

setuptool-1.12-1

So you need to reinstall the setuptool package as user root with

# rpm -Uvh --force setuptool-1.12.1.i386.rpm

Once that is reinstalled, fire up setup and go to TimeZone Selection,
select the appropriate time zone, and ensure that the box

System Clock Uses UTC

is NOT checked.
 
Old 08-06-2003, 09:58 AM   #9
chamanrana
LQ Newbie
 
Registered: Aug 2003
Location: India
Distribution: Red Hat
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for ur advice

Dear Corin,
Thanks a lot for ur effort and time to help me out. I am sure this will definately work and let u know on the same.
Thanks again,
Chaman
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Time Zone cherukuri_sr Linux - Newbie 2 02-02-2005 12:20 PM
Time Zone, DTS problem.... G-Fox Linux - Newbie 0 08-23-2004 06:57 AM
Display the date and time from another time zone lothario Linux - Software 4 07-31-2004 04:27 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 04:25 PM
time zone exigent Linux - General 4 09-17-2002 04:41 PM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration