LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-17-2005, 01:09 PM   #1
iskrem
LQ Newbie
 
Registered: Nov 2004
Location: Norway
Distribution: Gentoo
Posts: 25

Rep: Reputation: 15
Problem with sound in ET and Skype, simoutesly


I am trying to get sound in both Skype and Enemy-territory, simoutesly. I am starting skype with artsdsp skype. However when I start et with "artsdsp -m et", Enemy territory doesn't start, and when I kill it, it returns DOUBLE SIGNAL FAULT: Received signal 15, exiting...

I also get this error, which is probably more interesting:
------- sound initialization -------
*** glibc detected *** free(): invalid pointer: 0x09428d10 ***
Received signal 6, exiting...
/usr/local/bin/et: line 5: 6295 Killed artsdsp -m ./et.x86 $*

Anyone know how to fix this problem?

Last edited by iskrem; 03-17-2005 at 01:29 PM.
 
Old 03-18-2005, 03:11 AM   #2
iskrem
LQ Newbie
 
Registered: Nov 2004
Location: Norway
Distribution: Gentoo
Posts: 25

Original Poster
Rep: Reputation: 15
I don't have to use ARTS to mix the sounds from Skype and Enemy-Territory. Using ARTS is only a matter of making it work. Other suggestions is appreciated.
 
Old 03-18-2005, 08:23 AM   #3
Adony
Member
 
Registered: Apr 2004
Location: Portugal
Distribution: Gentoo 2004.2 - working on LFS 6
Posts: 126

Rep: Reputation: 15
Well you could try another sound routing daemon like esd and see if it works with ET
 
Old 03-18-2005, 12:43 PM   #4
iskrem
LQ Newbie
 
Registered: Nov 2004
Location: Norway
Distribution: Gentoo
Posts: 25

Original Poster
Rep: Reputation: 15
By using esddsp I can start ET, but I get this error.

------- sound initialization -------
- using device default
- using device default
Sorry but your soundcard can't do this
------------------------------------
 
Old 03-19-2005, 11:08 AM   #5
iskrem
LQ Newbie
 
Registered: Nov 2004
Location: Norway
Distribution: Gentoo
Posts: 25

Original Poster
Rep: Reputation: 15
I have read many threads about this issue, but nothing works for me .
 
Old 03-19-2005, 02:02 PM   #6
Adony
Member
 
Registered: Apr 2004
Location: Portugal
Distribution: Gentoo 2004.2 - working on LFS 6
Posts: 126

Rep: Reputation: 15
Well try playing it the esd configuration ...
I run esd as a daemon so it spawns automatically when an app tryes to access the osund card! It works perfectly with xmms and UT ... Try doing that and run ET without the initial esddsp command ...

There is my esd configuration
[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2
spawn_wait_ms=100


Hope that helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound, xmms and skype solution for ubuntu eerstkoffie Ubuntu 0 08-25-2005 07:42 AM
Sound problem with Skype der_kaiser1 Ubuntu 5 08-01-2005 12:42 PM
Skype: "Problem with Sound Device" Gay R0b0t Suse/Novell 1 06-12-2005 07:36 PM
skype:bad sound laurentwahl Linux - General 6 05-30-2005 11:21 AM
How and what programs do I associate with Skype to hve sound rafty114 Linux - Software 2 03-02-2005 04:10 PM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration