LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 06-12-2001, 06:15 PM   #1
jcontess
LQ Newbie
 
Registered: Jun 2001
Posts: 2

Rep: Reputation: 0
Angry


I am installing RH 7.1 in my Gateway 2000 P5-90 with 40MB RAM. I have installed RH 6.2 and 7.0 without any problems. The specific problem is that when I use the boot disk (motherboard doesn't support cd-rom boot) the hard disk and cd-rom drives don't get detected. Trying to solve the problem I used the RH 7.0 boot disk with the RH 7.1 cd, it installed correctly and it boots until it starts probing the IDE devices and gets stuck and gives a kernel panic error.

Any ideas?

Thanks
 
Old 06-13-2001, 05:57 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,534
Blog Entries: 51

Rep: Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604
just a remark, it would help to post ure hardware configuration and if u know it, the modules that where needed under earlier versions of red hat.
my ESP is buggy and I still can't smell hardware :-]
 
Old 06-14-2001, 11:08 AM   #3
jcontess
LQ Newbie
 
Registered: Jun 2001
Posts: 2

Original Poster
Rep: Reputation: 0
Post

I have an Intel Pentium 90MHz, NEC CD-ROM DRIVE (CDR-260) as hdb, 40MB RAM, Western Digital 2.1 MB HD as hda. How can I know what modules the older versions used?
I also tried passing the "hdb=cdrom" parameter with no luck.
 
Old 06-14-2001, 12:43 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,534
Blog Entries: 51

Rep: Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604
weird it works in 7.0 and not with 7.1. even tho the P5-90 is relatively old (siz years I think?).
your CDR is non-ATAPI, I think with a recompile of the kernel u can add it, but Im not sure about that.
the Gateway 2000 P5-90 motherboard possibly has buggy RZ-1000 and/or CMD640 EIDE chips. I know with a kernel recompile can add support for it.

Ive looked around, but found no other clues than adding "hda=serialize" at the bootprompt.
It isnt the most pretty option but if no one has a definitive answer I would suggest installing 7.0 again and upgrade over that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
shell script to detect IDE devices kushalkoolwal Programming 8 09-28-2005 11:15 AM
Mandrake can't detect my wireless devices joshknape Mandriva 25 09-07-2005 11:26 PM
Can't detect usb devices?? CM019 Debian 5 06-09-2005 01:43 PM
Can I have more than 4 IDE devices in my PC? Joe Soap Linux - Hardware 7 02-26-2005 08:52 AM
Can Hotplug detect USB devices in a certain order? SAM_site Linux - General 0 07-10-2004 07:27 AM


All times are GMT -5. The time now is 11:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration