LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 06-30-2007, 03:52 AM   #1
yohan2k
LQ Newbie
 
Registered: Jun 2007
Posts: 3

Rep: Reputation: 0
Problem with old program in the X Window System


I just installed Xorg on a really old unix machine. The software which im running use to be running on an old legacy system with 8bit color depth.
Now when running in 8bit mode with xorg, its all screwed up...the colors are all strange and weird everywhere on the screen...including on the program which im trying to display
If i run in 24 bit mode on the other hand, everything is fine...except that the program in question has all strange colors

Why is this? Can I fix this somehow?
As an extreme solution, is it possible to turn to black and white? So at least the text is readable....the text in both modes is unreadable because of strange color problem.

Johan
 
Old 06-30-2007, 02:12 PM   #2
studioj
Member
 
Registered: Oct 2006
Posts: 460

Rep: Reputation: 31
the problem is in the video driver you are using.
you didn't say what video device you have so we cant help alot more.
one thing to note is starting with the change to modular X design begining with XFree4 and then moving to Xorg many of the very old video drivers never made the transition and got left behind.
So one solution for very old machines is to uninstall xorg and compile Xfree3 and use it.
 
Old 07-01-2007, 02:55 AM   #3
yohan2k
LQ Newbie
 
Registered: Jun 2007
Posts: 3

Original Poster
Rep: Reputation: 0
I'm using an intel graphics card which is dedicated. To be honest, I don't know more about the problem than what I am writing. I don't have access to the machine because of restrictions, but my co-workers have access. We are using the latest intel drivers and it seems to work in the unix environment. Is there any information, which I can look up to make my question more clear?

I'll try what you wrote, thanks for your help!

Johan
 
Old 07-05-2007, 01:48 PM   #4
yohan2k
LQ Newbie
 
Registered: Jun 2007
Posts: 3

Original Poster
Rep: Reputation: 0
bump!

Nobody else has any idea? Really really need this fixed.
 
Old 07-05-2007, 01:52 PM   #5
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 114Reputation: 114
You were asked to provide information about the video driver. You didn't.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The program 'stepmania' received an X Window System error. Predatornica Linux - Software 4 06-29-2007 09:26 AM
x-window-system install problem kishoyian Debian 1 03-23-2006 11:26 AM
The program 'xchat' received an X Window System error. datbenik Linux - Software 1 12-09-2005 08:08 AM
problem with X window system Lenny420 Linux - Software 3 06-09-2005 03:13 AM
Problem Configuring X Window System MysteryNad Linux - Hardware 10 03-16-2003 09:38 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration