LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-30-2003, 11:35 AM   #1
infra
LQ Newbie
 
Registered: Sep 2003
Location: Mexico
Distribution: Mandrake 9.0
Posts: 2

Rep: Reputation: 0
Unhappy problem with library libc.so.6


Hi
I got a problem installing many programs because all of them depend on libc.so.6, i have the rpm containing it and when i try to install/update gives me the following
[root@localhost Download]# rpm -Uvh glibc-2.3.1-10mdk.i586.rpm

error: failed dependencies:
initscripts < 6.91-18mdk conflicts with glibc-2.3.1-10mdk
glibc = 2.2.5 is needed by locales-2.3.1.3-7mdk
glibc = 2.2.5 is needed by locales-2.3.1.3-7mdk
glibc = 2.2.5-16mdk is needed by glibc-devel-2.2.5-16md

and if i try to -ivh instead it only gives me the initscripts error
what is initscripts? can I remove it or is it very important?

 
Old 10-01-2003, 09:00 PM   #2
infra
LQ Newbie
 
Registered: Sep 2003
Location: Mexico
Distribution: Mandrake 9.0
Posts: 2

Original Poster
Rep: Reputation: 0
please someone help me!

now i know that the initscripts library is were all the scripts for booting the computer are, but I still don't know what to do
I have glibc 2.2.5 installed but i need to uograde to 2.3.1 and it gives me the conflicts error, so i don't know what to do

SOMEONE HELP ME!!!!!!!!!!!
 
Old 10-26-2003, 12:25 AM   #3
Hytec
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.0, 9.1
Posts: 1

Rep: Reputation: 0
Lightbulb Maybe this will help.

Follow this link, this should help you. I have the same problem.

http://at.rpmfind.net/opsys/linux/RP...2mdk.i586.html
http://at.rpmfind.net/opsys/linux/RP...0mdk.i586.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kmodule: error while loading shared library libc.so.6 gruell Fedora - Installation 2 08-04-2005 10:24 AM
Problem with libc.6.so CmdrChopper Linux - Newbie 1 10-24-2004 07:55 PM
libc problem thrix Programming 1 02-01-2004 10:53 AM
RPM - stupid problem with libc.so.6 uFoQ Linux - Software 3 09-06-2003 04:57 PM
libc.so.6 problem ih8linux Linux - Software 11 04-21-2003 03:08 PM


All times are GMT -5. The time now is 07:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration