LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem with libgio-2.0.so.0 (I've broken my system) (http://www.linuxquestions.org/questions/linux-software-2/problem-with-libgio-2-0-so-0-ive-broken-my-system-867795/)

Sanva 03-10-2011 05:13 PM

Problem with libgio-2.0.so.0 (I've broken my system)
 
Hi!

I have a problem with libgio-2.0 —well... I don't know where the problem really is :S

I have compiled and installed GLib 2.28, and I now I think it was a bad idea... I needed it to compile Nautilus but now my system is totally broken.

When I try to run some kind of applications I always get an error, for example:

Code:

$ gedit
gedit: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_cclosure_marshal_VOID__VARIANT

or

Quote:

$ google-chrome
/usr/bin/google-chrome: symbol lookup error: /usr/lib/libgio-2.0.so.0: undefined symbol: g_cclosure_marshal_VOID__VARIANT
I've been looking over there and I saw similar errors, but I don't know how to fix mine. I've reinstalled GLib 2.24.1 using apt-get but now I get a similar error:

Code:

$ gedit
gedit: symbol lookup error: /usr/lib/libgobject-2.0.so.0: undefined symbol: g_date_time_unref

What could I do?

I leave you here the output of ldd because I've saw over there that it was useful to correct similar problems.

Code:

$ ldd /usr/bin/gedit
        linux-gate.so.1 =>  (0xb77f7000)
        libgtksourceview-2.0.so.0 => /usr/lib/libgtksourceview-2.0.so.0 (0xb7777000)
        libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0xb7745000)
        liblaunchpad-integration.so.1 => /usr/lib/liblaunchpad-integration.so.1 (0xb773f000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb736a000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb72d4000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb72b8000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xb71b5000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb719a000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb7120000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb70dd000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb709a000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb7095000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb708e000)
        libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0xb6fc4000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb6ea7000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb6e9e000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb6e78000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb6e5e000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb6d04000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb6ceb000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6cdf000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6bb4000)
        libORBit-2.so.0 => /usr/lib/libORBit-2.so.0 (0xb6b61000)
        libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb6b42000)
        libdbus-1.so.3 => /lib/libdbus-1.so.3 (0xb6b09000)
        librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0xb6b00000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb6af0000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb6ae6000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb6ae1000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xb6ad3000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb6acb000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb6ac1000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xb6abd000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb6ab8000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb6ab2000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb6a8b000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6a15000)
        libz.so.1 => /lib/libz.so.1 (0xb6a00000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb69cf000)
        libresolv.so.2 => /lib/tls/i686/cmov/libresolv.so.2 (0xb69bb000)
        libselinux.so.1 => /lib/libselinux.so.1 (0xb69a0000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xb6946000)
        libdirectfb-1.2.so.0 => /usr/lib/libdirectfb-1.2.so.0 (0xb68cf000)
        libfusion-1.2.so.0 => /usr/lib/libfusion-1.2.so.0 (0xb68c4000)
        libdirect-1.2.so.0 => /usr/lib/libdirect-1.2.so.0 (0xb68ae000)
        libpng12.so.0 => /lib/libpng12.so.0 (0xb6889000)
        libxcb-render-util.so.0 => /usr/lib/libxcb-render-util.so.0 (0xb6884000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0xb687c000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb6861000)
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb685d000)
        libpcre.so.3 => /lib/libpcre.so.3 (0xb682c000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb6827000)
        /lib/ld-linux.so.2 (0xb77f8000)
        libexpat.so.1 => /lib/libexpat.so.1 (0xb67ff000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb67fb000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb67f5000)

I'm using Linux Mint 9 with Gnome 2.30.1 and my kernel version is 2.6.32-21-generic (i686).

Thanks in advance for your time —and sorry if my English is bad.

knudfl 03-10-2011 05:46 PM

Changing glib2 / atk / pango / cairo / gtk2 to a different version is one of the
most difficult things to do: Very little chance that later versions are compatible.

To see how many applications it is about, you can do this test :
sudo apt-get remove libglib2.0-0 ( And don't say 'yes' to execute the removal.)
> > A list of all the packages that depend on glib2 will be shown,
and that's usually 500..600 packages.

Solution : Use Mint 10 instead.

..

Sanva 03-11-2011 04:39 AM

Quote:

To see how many applications it is about, you can do this test :
sudo apt-get remove libglib2.0-0 ( And don't say 'yes' to execute the removal.)
Yes, I've seen that. The most funny part is that I think I could write "yes" and I think that nothing would happen... because it says to me "Está a punto de hacer algo potencialmente dañino. Para continuar escriba la frase «Sí, ¡haga lo que le digo!»" [You'll do something potentially harmful. To continue write the sentence «Yes, do what I say!» ]

Quote:

Solution : Use Mint 10 instead.
Yes... I've though that doing an upgrade could fix it... I will try it and if it doesn't work I'll simply install a fresh Linux Mint 10.

Thanks for your time.

drosophila 04-07-2011 07:30 AM

The problem is that your distribution has put a copy of glib in /lib for low-level services to use but when you installed the newer version of glib it only copied the library to /usr/lib. Hence the problem with incompatible bits of glib.


All times are GMT -5. The time now is 07:35 AM.