LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-13-2003, 10:19 AM   #1
k0ljat
Member
 
Registered: Apr 2003
Location: Underground
Distribution: Slackware
Posts: 103

Rep: Reputation: 15
Problem with gmplayer


Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /root/.such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'

mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'



^^^ this is the error when im trying to play gmplayer, i assume that the problem is with Skins, i downloaded a nice little skin package, extracted it to the Skin directorys, but i get still the same problem...


OS: slack
 
Old 10-13-2003, 10:39 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
When you installed mplayer, did you use the "--enable-gui" switch? It looks as though mplayer cannot find the codecs, skins or fonts. I am assuming that this is what you see when you type 'gmplayer' into a console.

The skin that you want to use needs to be named 'default'.

Can you tell me how you installed the program (with or without gui?), the fonts, the codecs and the skins.
 
Old 10-13-2003, 10:45 AM   #3
k0ljat
Member
 
Registered: Apr 2003
Location: Underground
Distribution: Slackware
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by XavierP
When you installed mplayer, did you use the "--enable-gui" switch? It looks as though mplayer cannot find the codecs, skins or fonts. I am assuming that this is what you see when you type 'gmplayer' into a console.

The skin that you want to use needs to be named 'default'.

Can you tell me how you installed the program (with or without gui?), the fonts, the codecs and the skins.

i used --enable-gui command, and i got it working, but now i have another problem, only when using GUI it gives me an error (-vo) device something.. what to do ?!
 
Old 10-13-2003, 10:53 AM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Did you install the codecs and fonts?

Is this your error message?
Quote:
Green image using mga_vid (-vo mga / -vo xmga).
This may be of help.
 
Old 10-13-2003, 10:59 AM   #5
chup
Member
 
Registered: Aug 2003
Location: South Africa
Distribution: Ubuntu (Feisty)
Posts: 280

Rep: Reputation: 30
i first had the same probs, you should download a skin, and extract it to ~/.mplayer/Skin/default
that did the trick for me
 
Old 10-13-2003, 11:12 AM   #6
k0ljat
Member
 
Registered: Apr 2003
Location: Underground
Distribution: Slackware
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by XavierP
Did you install the codecs and fonts?

Is this your error message?

This may be of help.

No, the error is :


Error opening/initializing the selected video_out(-vo) device.
 
Old 10-13-2003, 11:22 AM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
By Googling your error message, eventually, I found this:
Quote:
I wanted to play some movies with gmplayer.
Got this error:
Error opening/initializing the selected video_out (-vo) device.

I have no special 3d video card on this machine, so I think, need to use the x11 or xv output.
Tested first mplayer directly from command line.

# mplayer -vo x11 -framedrop -dvd 1 md305c3y.mov (OK)
# mplayer -vo x11 -framedrop -dvd 1 h1.avi (OK)

And added these lines into "/usr/local/etc/mplayer/mplayer.conf" (? read: man mplayer)
(alternatively add the lines into your private "$HOME/.mplayer/config"

# cat /usr/local/etc/mplayer/mplayer.conf
# Write your default config options here!
vo=x11
# flip=yes (uncomment this and do neck-wrestling)
mf=type=png:fps=25
Does this help?

I am, of course assuming that your install was:
$ ./configure --enable-gui
$ make
# make install

You did compile the prog manually, yes?
 
Old 10-13-2003, 11:55 AM   #8
k0ljat
Member
 
Registered: Apr 2003
Location: Underground
Distribution: Slackware
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by XavierP
By Googling your error message, eventually, I found this:


Does this help?

I am, of course assuming that your install was:
$ ./configure --enable-gui
$ make
# make install

You did compile the prog manually, yes?

no, that search wasent any help for me, and yes i installed it with ./configure --enable-gui
 
Old 10-13-2003, 12:04 PM   #9
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
And the skins/fonts/codecs - did you install all of them according to the instructions? Did you install the skin to the correct directory and call it default?
 
Old 10-13-2003, 12:17 PM   #10
k0ljat
Member
 
Registered: Apr 2003
Location: Underground
Distribution: Slackware
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by XavierP
And the skins/fonts/codecs - did you install all of them according to the instructions? Did you install the skin to the correct directory and call it default?

ill told you, the skins are all okay... only the (-vo) problem
 
Old 10-13-2003, 12:24 PM   #11
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Quote:
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
Can't open input config file /root/.such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root or /dev/rtc should be readable by the user.)
From this: it can't open fonts. Do you have any? Are they in the correct places? Did you install them as per the instructions?
Ditto for the codecs.
 
Old 10-13-2003, 12:55 PM   #12
k0ljat
Member
 
Registered: Apr 2003
Location: Underground
Distribution: Slackware
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by k0ljat
i used --enable-gui command, and i got it working, but now i have another problem, only when using GUI it gives me an error (-vo) device something.. what to do ?!

i brought this post up because some of you didnt understand that i got the problem fixed with the gui ...
 
Old 10-13-2003, 03:36 PM   #13
swell
LQ Newbie
 
Registered: Jul 2003
Location: Atlanta, GA
Distribution: SuSE
Posts: 17

Rep: Reputation: 0
the vo- problem doesn't affect anything but an error message(could be a non-important bug). I prefer to use mplayer rather than gmplayer.
 
Old 11-22-2003, 03:32 PM   #14
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
that -vo msg (Error opening/initializing the selected video_out (-vo) device) shows up is because by default, gmplayer is looking for mga_vid under /dev,

if you have that graphic card (g200 or g400 from matrox) , then you can compile it into the kernel and gmplayer / mplayer will look for it from /dev/mga_vid

if you don't. then you may wanna use X11, gmplayer -vo x11. or just type: mplayer -vo help , it will tells you all the viedo card it supports.

best wish



p.s: if you don't have g200 or g400, ./configure --disable-mga

./configure -help will shows you what viedo card can be enable and disable as default.

Last edited by sirpelidor; 11-22-2003 at 03:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gMplayer problem cain_eve Linux - Software 6 04-11-2005 02:10 PM
problem with gmplayer Paxmaster Linux - Software 1 10-10-2004 04:02 AM
GMplayer problem...(Please Help) RoaCh Of DisCor Linux - Software 7 09-21-2004 01:22 PM
gMplayer problem ansemax Slackware 3 11-25-2003 08:58 PM
gmplayer problem illtbagu Linux - Software 5 02-01-2003 06:49 PM


All times are GMT -5. The time now is 02:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration