LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-24-2004, 10:01 AM   #1
mavinac
LQ Newbie
 
Registered: Sep 2003
Location: Czech Republic
Distribution: Mandrake 10
Posts: 9

Rep: Reputation: 0
Problem with dependencies of libs from OpenSSL


Hello,
I would like to install program ntop (but it is not so important I think), but there is required libs from OpenSSL (f.e. libssl.so.4 and others). I am sure that I have OpenSSL instaled ( v. 0.9.7a-1.3.91mdk) but when dependency check is performed it looks like if OpenSSL is not installed. I am running Mandrake 9.1 . Can you help me what do with it?
 
Old 03-24-2004, 10:32 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
What is the exact error you recieve? Are you installing as root or a user? Is it in your current path?
 
Old 03-24-2004, 10:55 AM   #3
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
If you are building from source you need the OpenSSL development package from your distribution in addition to the OpenSSL programs and libraries.


Håkan
 
Old 03-24-2004, 11:03 AM   #4
mavinac
LQ Newbie
 
Registered: Sep 2003
Location: Czech Republic
Distribution: Mandrake 10
Posts: 9

Original Poster
Rep: Reputation: 0
error message which I recieved is:

error: failed dependencies:

libname : is required for ntop-3.0-0

Yes I'm logged as root.

I hope so, previously (for some month ago) I had install for example direct connect (where opensll is also needed) and there were not these problems.
 
Old 03-24-2004, 11:04 AM   #5
mavinac
LQ Newbie
 
Registered: Sep 2003
Location: Czech Republic
Distribution: Mandrake 10
Posts: 9

Original Poster
Rep: Reputation: 0
I am installing from rpm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
openssl problem James_dean Programming 0 09-22-2005 06:10 AM
Problem with OpenSSL and sockets alitrix Programming 3 07-08-2005 01:45 PM
openssl problem abdullahgee Programming 0 06-03-2004 03:00 PM
redhat 9 frustration....... :/ "krb5-libs" and "openssl" DraaX Linux - Newbie 3 07-25-2003 06:40 PM
openSSL problem raven Linux - Software 2 09-15-2002 12:24 PM


All times are GMT -5. The time now is 02:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration