LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem with Bind (http://www.linuxquestions.org/questions/linux-software-2/problem-with-bind-4175430017/)

barnum 10-02-2012 04:33 AM

Problem with Bind
 
Any create trouble shooting advice will help. Here's my situation.

I have a named server for my inside domain, which is also a forwarder. It does not appear to be forwarding. I've eliminated routing issues as I can ping anything on the internet using strictly IP.

I double checked that fowarders are configured, and have tried with and without

Code:

forward only;
having the same result.

Here's a packet capture that better describes what is happening.

Code:

04:04:40.985153 IP redhatdns1.domain.local.64221 > dns-cac-lb-02.rr.com.domain: 46278+% [1au] A? google.com. (39)
04:04:41.009091 IP dns-cac-lb-02.rr.com.domain > redhatdns1.domain.local.64221: 46278 11/0/0 A 74.125.227.99, A 74.125.227.100, A 74.125.227.101, A 74.125.227.102, A 74.125.227.103, A 74.125.227.104, A 74.125.227.105, A 74.125.227.110, A 74.125.227.96, A 74.125.227.97, A 74.125.227.98 (204)
04:04:41.009825 IP redhatdns1.domain.local.domain > host12.domain.local.58606: 62553 ServFail 0/0/0 (28)

If you look closely, you'll see that the configured dns server redhatdns1 requests information about 'google.com', gets a reply (verified to be good IPs), and still forwards 'fail' to host12.

Any ideas?

bathory 10-02-2012 11:25 AM

Quote:

04:04:41.009825 IP redhatdns1.domain.local.domain > host12.domain.local.58606: 62553 ServFail 0/0/0 (28)
Check the zone file to see why you get the error in bold above

barnum 10-03-2012 02:18 AM

Logs revealed insecure source so it wasn't passing the resolved addresses along. Adjusted time, fixed now. Thanks!


All times are GMT -5. The time now is 11:18 AM.