LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-22-2003, 09:47 PM   #1
jaberwooky
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Problem with Apache Virtual Hosts


I have eight Virtual Hosts running on my server, none of which I had any problems with. I recently attempted to add a new Virtual Host and ran into problems. I looked at the error_log which reads:

Directory Index forbidden by rule: /var/www/html/somedir/

I went back and checked all of the permissions, /var/www/html/somedir is set to 755 and all files within the folder are 644. The owner and group are the same as all the other virtual hosts that work fine.

In a last ditch effort to fix the problem before posting this, I ran chmod 777 -R /var/www/html/somedir and then restarted apache, with no avail.

Any Suggestions?

Last edited by jaberwooky; 09-22-2003 at 09:54 PM.
 
Old 09-23-2003, 12:38 AM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
I'd say it's rather a problem with the setup of DirectoryIndex in your conf file for the virtual. Check that setting, be sure you've set that up correctly again.

Which version of Apache is this anyway, and what distro?

Welcome to LQ

Cool
 
Old 09-23-2003, 01:06 AM   #3
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
"DirectoryIndex" is for naming files you want to serve as you index files. e.g. index.html, index.htm

I think your looking for:
Options FollowSymLinks Indexes

EG.
<Directory "/home/someuser/browsable">
Options FollowSymLinks Indexes
Order allow,deny
Allow from all
</Directory>
 
Old 09-23-2003, 02:19 PM   #4
jaberwooky
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Problem Solved

Thanks,

It was an issue with the DirectoryIndex. The person I was setting up the virtual host for has a habit of captializing the first character of filenames. I had the DirectoryIndex set to index.html the file name was Index.html.
 
Old 09-23-2003, 02:37 PM   #5
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Usually is just one character. Glad you found it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd, web uploads, vsftpd virtual users, apache virtual hosts, home directories jerryasher Linux - Software 7 02-18-2007 07:29 AM
apache virtual hosts smaida Linux - Software 3 06-20-2004 05:28 PM
Apache Virtual Hosts gbg Linux - Software 4 10-02-2003 09:35 AM
Apache virtual hosts Mil0 Linux - Software 5 06-02-2003 12:58 AM
apache virtual hosts jonfa Linux - General 1 06-04-2002 02:50 AM


All times are GMT -5. The time now is 11:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration