LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-10-2004, 05:01 AM   #1
czarherr
Member
 
Registered: Sep 2003
Location: Suwon, Korea
Distribution: Slackware 14
Posts: 288

Rep: Reputation: 32
problem with apache 1.3.27


Im setting up an apache webserver, and so far, i have it connected to the internet and everything, serving my page, with one small problem. it just prints the index of my page. Im not sure if its because im using php and javascript, although i have both enabled and the php module loaded into apache. here is the site, id really appreciate any insight on this, as i need to have this up soon, and while it was no sweat in windows, the linux version is really starting to frustrate me, but dont get me wrong, im not going back to windows, this is one of few big problems ive had. Ive made some progress, and am now able to click the php page and get my website, but i still cant get that to be the page that loads automatically, instead i still get the index page.

Last edited by czarherr; 01-10-2004 at 05:20 AM.
 
Old 01-10-2004, 08:45 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
By index I assume you mean a list of files? You need to edit httpd.conf and add the name of the file that you want to appear instead of the index - ie "home.php" to the DirectoryIndex directive.
 
Old 01-10-2004, 12:38 PM   #3
czarherr
Member
 
Registered: Sep 2003
Location: Suwon, Korea
Distribution: Slackware 14
Posts: 288

Original Poster
Rep: Reputation: 32
awesome, worked like a charm, greatly appreciated, afferoing away as we speak
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange apache trailing / problem - Slack-current, apache 1.3.33 vamp Linux - Networking 1 01-30-2005 08:28 PM
RH9: PHP session problem (or Apache problem) fengcn Red Hat 0 12-01-2003 07:32 PM
Apache problem mehesque Linux - Networking 2 10-24-2003 12:38 PM
perl problem? apache problem? cgi problem? WorldBuilder Linux - Software 1 09-17-2003 08:45 PM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 11:53 AM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration