LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-23-2004, 06:45 PM   #1
Tifozi_F1
LQ Newbie
 
Registered: Feb 2004
Distribution: Red Hat 9
Posts: 5

Rep: Reputation: 0
Unhappy Problem installing XMMS


Hi, I am new here and also new to the linux community. I want a help about installing the new version of xmms 1.2.10. I have the 1.2.7 and when I add or try to play a song nothing happens. So a friend told me to down load the latest software. I downloaded the xmms-1.2.10-1.i386.rpm file and in the terminal i wrote (as a root) rpm -i and the name of the file but then it says that alot of files of 1.2.10 config with the files of 1.2.7. As an examle is :
file /usr/bin/wmxmms from install of xmms-1.2.10-1 conflicts with file from package xmms-1.2.7-21.p
I dont know what to do. I am starting now so I want your help. Thanks in advance.

Greetings,
tifozif1
 
Old 02-23-2004, 06:59 PM   #2
kegwell
Member
 
Registered: Feb 2004
Distribution: Gentoo Linux
Posts: 46

Rep: Reputation: 15
You need to run the -U switch for upgrade and not the -i for install. you already have xmms installed so that is why it is giving you the conflict errors. Either do that or -e to completely remove xmms, then install new version. It's not like windows where it just writes over current files at will. Run 'man rpm' at term for more switches.

--Matt
 
Old 02-23-2004, 08:43 PM   #3
linux-fan64
LQ Newbie
 
Registered: Feb 2004
Location: Wisconsin, USA
Distribution: Mandrake 10 Official
Posts: 17

Rep: Reputation: 0
Also to install....

I am also new, but went through similar setup. First off, you'll have to download all the files for the particular release. (just installed v1.2.9) There were 3 rpm's for the install. Put them all in the same folder, and then run the command 'rpm -Fvh *.rpm' and it will run them all at once and do the install. Also, when you have xmms up and running, go to OPTIONS>PREFERENCES>OUTPUT PLUGIN and be sure it's set to play to your sound system, (Like OSS Driver v1.2.x) and that its NOT set to the disk writer plug-in. Thats where I found my problem was
 
Old 02-25-2004, 12:49 PM   #4
Tifozi_F1
LQ Newbie
 
Registered: Feb 2004
Distribution: Red Hat 9
Posts: 5

Original Poster
Rep: Reputation: 0
Thank u my friends for your replies. I have tried but with no success. I have downloaded the three files: 1)xmms-1.2.10-1.i386.rpm 2) xmms-debuginfo-1.2.10-1.i386.rpm 3) xmms-devel-1.2.10-1.i386.rpm. In the terminal I wrote rpm -U xmms-1.2.10-1.i386.rpm and the result was this: error: Failed dependencies:
xmms = 1.2.7 is needed by (installed) xmms-devel-1.2.7-21.p

Then I typed rpm -U xmms-devel-1.2.10-1.i386.rpm and the result was: error: Failed dependencies:
xmms = 1:1.2.10 is needed by xmms-devel-1.2.10-1

So nothing happend. I dont know what to do. About the erase I dont know how to do it exactly. Thank u in advance.

Greetings,
tifozif1
 
Old 02-25-2004, 03:49 PM   #5
linux-fan64
LQ Newbie
 
Registered: Feb 2004
Location: Wisconsin, USA
Distribution: Mandrake 10 Official
Posts: 17

Rep: Reputation: 0
Yoohoo :)

Re-read how I had said to try it using the -F command with *.rpm
 
Old 02-25-2004, 05:14 PM   #6
Tifozi_F1
LQ Newbie
 
Registered: Feb 2004
Distribution: Red Hat 9
Posts: 5

Original Poster
Rep: Reputation: 0
Thank u my friend linux-Fan64 I did what u said and everything is OK now. I tried it before but the mistake I was doing is I the space between -Fvh and the *. I did't put space but then I figure it out. Thanks a lot.

Greetings,
tifozif1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Installing Xmms neogeek77 Linux - Software 2 11-23-2005 06:34 AM
Problem installing XMMS and rpms in general. remz Linux - Software 3 07-27-2004 01:10 AM
problem installing xmms 1.2.10 on Mandrake 9.2 thongkh Linux - Software 5 04-03-2004 01:46 AM
Installing XMMS, Problem with glib Inexactitude Linux - Software 3 10-18-2003 05:01 PM
problem installing avi-xmms-1.2.3 valueduser Linux - Software 5 09-04-2002 03:24 PM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration