LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-20-2003, 10:04 PM   #1
hex
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9 (Dolphin)
Posts: 11

Rep: Reputation: 0
Problem installing xchat...


Here's the last few lines I get when I try to compile xchat:

perl.c: In function `perl_end':
perl.c:1089: warning: implicit declaration of function `perl_destruct'
perl.c:1090: warning: implicit declaration of function `perl_free'
make[3]: *** [perl.lo] Error 1
make[3]: Leaving directory `/root/xchat-2.0.1/plugins/perl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/xchat-2.0.1/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/xchat-2.0.1'

Yikes.. I am clueless as to what's wrong.. I had installed xchat before (with alot of problems), but now I really have no idea what I'm doing wrong?
Any help would be greatly appreciated! Please bear in mind I'm a newbie and need a simplified explanation of what to do
Thanks in advance!
 
Old 04-21-2003, 10:50 AM   #2
Womandrake
Member
 
Registered: Apr 2003
Distribution: Mandrake 9.1 (Bamboo)
Posts: 46

Rep: Reputation: 15
It's me "hex".. maybe this will help:
When I try to configure I get this:

xchat 2.0.1

Building GTK+ Interface .... : yes
Building TEXT Interface .... : yes

PLUGINS: Perl: yes Python: no TCL: yes

mmx tinting ......... : yes
plugin interface .... : yes nls/gettext ......... : yes
link with socks5 .... : no text backend ........ : pango
openssl support ..... : no ipv6 support ........ : no

The binary will be installed in /usr/local/bin

Then I "make and pray" and still get the errors in my previous post. I'm at a loss Any help would be much appreciated. Thanks in advance.
 
Old 04-21-2003, 02:55 PM   #3
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Sounds like your Perl headers are the wrong version. Do

./configure --help

and look through the options for the Perl switch, you should be able to run something like

./configure --disable-perl

to switch off support for perl plugins (you don't want them anyway most likely)
 
Old 04-24-2003, 10:39 AM   #4
Womandrake
Member
 
Registered: Apr 2003
Distribution: Mandrake 9.1 (Bamboo)
Posts: 46

Rep: Reputation: 15
thanks for your reply mhearn.. I found this when trying to install:

perl.c:116:20: EXTERN.h: No such file or directory
perl.c:118:18: perl.h: No such file or directory
perl.c:119:18: XSUB.h: No such file or directory
perl.c:122: parse error before '*' token
perl.c:122: warning: type defaults to `int' in declaration of `my_perl'
perl.c:122: warning: data definition has no type or storage class
perl.c:128: parse error before "CV"
perl.c: In function `execute_perl':

Then I read somewhere over the net someone experiencing this same problem

http://www.rice.edu/perl4lib/archive.../msg00058.html

Apparently there's a problem with the perl package that comes with mandrake? A file called perl.h or something is missing.. how do I go about fixing this? Any ideas anyone?
 
Old 04-24-2003, 11:24 AM   #5
Womandrake
Member
 
Registered: Apr 2003
Distribution: Mandrake 9.1 (Bamboo)
Posts: 46

Rep: Reputation: 15
Well, this update: I did what you suggested mhearn, and finally installed xchat but I would still like to understand why I don't have the .h files mentioned above please?
 
Old 04-24-2003, 06:18 PM   #6
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
You probably need to install the perl-devel packages
 
Old 04-26-2003, 09:31 AM   #7
Womandrake
Member
 
Registered: Apr 2003
Distribution: Mandrake 9.1 (Bamboo)
Posts: 46

Rep: Reputation: 15
You were totally right Mike.. I was missing the perl and python packages.. installed everything and everything's working perfectly. Thanks!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Obsidian for XChat problem yohan77 Linux - Networking 0 08-09-2005 09:54 AM
Trouble with glib while installing xchat Kossu^2 Linux - Newbie 1 04-03-2005 11:25 PM
Problem compiling xchat... lingeek Solaris / OpenSolaris 3 03-06-2005 03:36 AM
Xchat -- xdcc problem Scorpio Linux - Software 1 03-05-2005 02:01 AM
xchat login problem emailssent Linux - Newbie 9 09-27-2004 03:47 AM


All times are GMT -5. The time now is 11:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration