LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   problem installing ruby on rails (http://www.linuxquestions.org/questions/linux-software-2/problem-installing-ruby-on-rails-655643/)

kathmanduite 07-14-2008 08:08 AM

problem installing ruby on rails
 
i am trying to install ruby on rail in RHEL4. I have installed ruby 1.8.6 via source. Then i installed rubygems as well via source. now when i try to install rails gem with the command

gem install rails

its giving error like
Zlib::GzipFile::Error
unexpected end of file

how should i install rails?

any help would be appreciated
thanks in advance.

trickykid 07-15-2008 12:34 PM

And you did run: ruby setup.rb when you installed rubygems?

What happens if you try: gem install rails --include-dependencies

kathmanduite 07-15-2008 11:02 PM

yes, I installed rubygems with : ruby setup.rb

I have installed zlib from http://www.zlib.net and ruby-zlib from http://raa.ruby-lang.org/project/ruby-zlib and I have re-installed ruby and rubygems as well.

This didn't help either. I am still getting same error.

ashishdubey 09-26-2012 11:29 AM

Did you try Installing Rails using RVM (Ruby enVironment Manager). It supports installing many a features for Ruby, Rubygems, Rails, Trace, etc.

$ curl -L get.rvm.io | bash -s stable --rails

Tinkster 09-26-2012 09:22 PM

Quote:

Originally Posted by ashishdubey (Post 4789917)
Did you try Installing Rails using RVM (Ruby enVironment Manager). It supports installing many a features for Ruby, Rubygems, Rails, Trace, etc.

$ curl -L get.rvm.io | bash -s stable --rails

Did you really just sign up to unearth carcasses from days gone by?

Two posts, both to threads that were dead for over 4 years ...

John VV 09-26-2012 09:50 PM

well this one is two( almost 3) years newer , but still RHEL4

Terminator3000 09-27-2012 06:59 AM

It is best to use RVM as in this tutorial for Centos 6


All times are GMT -5. The time now is 09:12 AM.