LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-06-2003, 08:40 AM   #1
LinuZ
Member
 
Registered: Jul 2003
Distribution: Mandrake 9.1
Posts: 38

Rep: Reputation: 15
Problem Installing, "Gift"


Hi, im trying to install Gift. I extracted the tarball, then go to the directory in konsole, and type
Code:
./configure && make && make install
It runs for a while, configuring and making, then I get this...

plugin.c' || echo './'`plugin.c
plugin.c:43:3: #error libltdl support is temporarily required, sorry!
make[3]: *** [plugin.o] Error 1
make[3]: Leaving directory `/home/mister/Documents/gift-0.11.3/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/mister/Documents/gift-0.11.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mister/Documents/gift-0.11.3'
make: *** [all] Error 2


Is it trying to tell me I need libtdl, or just some random error?

Thanks a bunch,
Matt
 
Old 08-06-2003, 09:03 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,571

Rep: Reputation: 171Reputation: 171
Yes, it requires a library you don't have. You cangt it from http://at.rpmfind.net/opsys/linux/RP...1mdk.i586.html
 
Old 08-06-2003, 11:54 AM   #3
ereeno
Member
 
Registered: Jul 2003
Location: New Westminster BC, Canada
Distribution: mandrake 9.1
Posts: 58

Rep: Reputation: 15
i installed that rpm but it is still giving me that same error message. is there anything additional that i have to do??

when i go through the rpm again it says "everything already installed", but making gift still gives me that error.
 
Old 08-11-2003, 01:41 AM   #4
digitalboi
Member
 
Registered: Jul 2003
Distribution: SUSE 9.2, Knoppix STD
Posts: 34

Rep: Reputation: 15
im running into the same problem, when i d/l the tar.gz then run tar -zxvf "thefile" it goes fine, when i ./configure it prints error that it will not support ltdl. I have libtools installed is there a way to point it to the place where that library is installed. ./configure --help doesnt have the options for it. Any help would be appreciated.
 
Old 08-11-2003, 04:06 PM   #5
eomerek
LQ Newbie
 
Registered: Aug 2003
Location: Warsaw, Poland
Distribution: Mandrake 10
Posts: 18

Rep: Reputation: 0
I've got this problem too:

Quote:
plugin.c:43:3: #error libltdl support is temporarily required, sorry!
make[3]: *** [plugin.o] Błąd 1 (error 1)
make[3]: Leaving directory `/home/jacek/tmp/giFT/src'
make[2]: *** [all-recursive] Błąd 1 (error 1)
make[2]: Leaving directory `/home/jacek/tmp/giFT/src'
make[1]: *** [all-recursive] Błąd 1 (error 1)
make[1]: Leaving directory `/home/jacek/tmp/giFT'
make: *** [all-recursive-am] Błąd 2 (error 2)
HELP!!
 
Old 08-11-2003, 04:13 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
you need to install the libtdl-devel rpm, not just the libtdl rpm itself.
 
Old 08-12-2003, 02:07 PM   #7
digitalboi
Member
 
Registered: Jul 2003
Distribution: SUSE 9.2, Knoppix STD
Posts: 34

Rep: Reputation: 15
During the install of libtdl-devel, it had a couple of dependencies for me to install, I have all of them installed except this devel(libdl). When i did a search on that file, I found it should be included in glibc-devel-2.3.1.10.mdk.rpm. Which i have installed. Can anybody point me in the right direction?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Skin not found" problem from installing Mplayer in Debian/Sarge !!! Blue Jacket Linux - Software 2 10-05-2005 01:58 AM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 04:51 AM
HD problem installing Fedora - "assertion failed" vinthund Linux - Software 1 02-24-2005 08:45 PM
Sound problem with "alsamixer" or "alsaconf" or sth else maybe... Mikuda Linux - Games 4 05-01-2004 11:09 AM
Gift trouble -- "libltdl support is temporarily required" TheChicken Linux - Software 1 10-26-2003 09:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration