LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-10-2004, 05:40 PM   #1
Einar Magnus
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Rep: Reputation: 0
Problem installing a KDE program


I have some problems with installing a KDE program that will help me run
dockapp's in KDE. It's calles Kdock or something. But when i try to run ./configure
this comes up:

Quote:
checking for Qt... configure: error: Qt (snapshot >= Qt 2.1 beta2) (libraries) not found. Please check your installation!
What the hell is that? and how do i fix it?

I get a error message almost everytime i try to install a new program!!!
Most of the errors are about libgnome. They say i don't have libgnome-2.0 or
something, but i have all types of libgnome, but it can't find the libgnome-2.0.pc!

What shall i do!? plz help me out!
 
Old 10-10-2004, 05:53 PM   #2
Einar Magnus
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Error

Here is the error message i usualy get:

Quote:
checking for libgnome-2.0 >= 2.0.0 libgnomecanvas-2.0 >= 2.0.0 libbonoboui-2.0 >= 2.0.0 gconf-2.0 >= 1.1.11 pango >= 1.1.2 gnome-vfs-2.0 >= 2.5.3 gnome-keychecking for libgnome-2.0 >= 2.0.0 libgnomecanvas-2.0 >= 2.0.0 libbonoboui-2.0 >= 2.0.0 gconf-2.0 >= 1.1.11 pango >= 1.1.2 gnome-vfs-2.0 >= 2.5.3 gnome-keyring-1... Package libgnome-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgnome-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnome-2.0' found

configure: error: Library requirements ( libgnome-2.0 >= 2.0.0 libgnomecanvas-2.0 >= 2.0.0 libbonoboui-2.0 >= 2.0.0 gconf-2.0 >= 1.1.11 pango >= 1.1.2 gnome-vfs-2.0 >= 2.5.3 gnome-keyring-1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.ring-1... Package libgnome-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgnome-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnome-2.0' found

configure: error: Library requirements ( libgnome-2.0 >= 2.0.0 libgnomecanvas-2.0 >= 2.0.0 libbonoboui-2.0 >= 2.0.0 gconf-2.0 >= 1.1.11 pango >= 1.1.2 gnome-vfs-2.0 >= 2.5.3 gnome-keyring-1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

SOMEONE PLZ HELP ME, I'M GOING MAD!
 
Old 10-10-2004, 05:54 PM   #3
crm
Member
 
Registered: Apr 2004
Location: leeds - UK
Distribution: Gentoo Stage 1 on Riser FS 4
Posts: 204

Rep: Reputation: 30
what distro are you running...
some of them dont put all the stuff needed to install new programs in with there basic installations...
try updating your installation to include the 'Development' stuffs.... generally if you cant install it afte rthis then theres somthing wrong
 
Old 10-11-2004, 05:14 AM   #4
Einar Magnus
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Original Poster
Rep: Reputation: 0
..?..

Quote:
Originally posted by crm
what distro are you running...
some of them dont put all the stuff needed to install new programs in with there basic installations...
try updating your installation to include the 'Development' stuffs.... generally if you cant install it afte rthis then theres somthing wrong
what is distro?
Can you tell me how to update it?
Can i urpmi it?
 
Old 10-12-2004, 04:20 AM   #5
crm
Member
 
Registered: Apr 2004
Location: leeds - UK
Distribution: Gentoo Stage 1 on Riser FS 4
Posts: 204

Rep: Reputation: 30
*reeds your signature*
duh - *bangs head on able*
im sorry, im an idiot!

your dirtro is mandrake linux 10....
i think if you put one of the install cd's in it should run a 'software update' thing (if not then there is a link to it in one of the settings menues) up date your software to include the developers tools -- that should work

Last edited by crm; 10-12-2004 at 04:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem compiling kde and another program poboy975 Linux - Software 3 01-18-2005 12:41 AM
Program installing problem nutz Linux - Software 5 11-23-2003 07:23 PM
problem while installing p2p program Par4n0iA Linux - Software 2 08-10-2003 08:30 AM
Problem installing KDE Red Guy Linux - Software 1 03-19-2003 02:25 AM
problem installing downloaded program shoot2kill Linux - Software 2 05-24-2002 03:07 PM


All times are GMT -5. The time now is 01:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration